SCP: Secret Laboratory - I am unable to verify the server with Northwood

System Information

Field Value
Operating System Windows - Windows 10 Pro on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization None
Application SCP: Secret Laboratory
Module GenericModule
Running in Container No
Current State Ready


Unable to Verify Server

Problem Description


I have been trying for over a month to get my server verified with Northwood. I have hosted other servers before outside of AMP and have not had a single issue. When I submit the verification request they tell me that the server is good and to copy my verification key over and that it should work. When I do this it will not work at all. I have had them reissue a new token for the key and have even tried deleting the instance and recreating it to no such luck. If there is anyone else having this problem and knows the answer please let me know.

Reproduction Steps

  • Create Instance
  • Start server verification
  • When approved, place Verification Key in AppData folder

Can you show in the AMP File Manager where you put the file?

And also how you uploaded the file? File perms may be an issue

Afaik, the file Verkey.txt is generated for you by the server once you complete the verification steps, and is created in your config directory. Maybe someone else running a server can confirm

Did you open the link they sent in your server’s console? If you missed the link you can right click the instance and View Logs to find it in there. Or I believe restarting the server showed it again.

The file is generated by Northwood after the verification is complete. I am running other servers on the same machine not through amp and they are working fine but the server is acting like it can’t read the file. So it keeps saying that the server is not verified. I have reached out to Northwood and they have refreshed the verkey and have even regenerated a new one for me to use and it still won’t work.

I am using the same key that I have been using for all my servers a Northwood says that it should be working for this server instance as well. This is the first time I have used AMP for SCP.

Where exactly is the key stored for the other non-AMP servers?

BTW, you never answered how you uploaded the key file to AMP.

I dragged and dropped. It uploaded it directly into the file path. The key matches the ones in my other servers. As to where they key is store in non-amp instances. It will be located in AppData/Roaming/SCP Secret Lab.

So it should go in AppData/SCP Secret Laboratory on AMP

Yes that is where the file is right now but the server still is showing that the server is not verified.

Not according to your screenshot?

It is, the Folder named SCP Secret Laboratory is plugins.

The Northwood CIO told me how to configure the template so that the relevant directories and files were all in the datastore, using the same method that hosting companies use. If it’s not working there then that is Northwood’s fault.

The other suggestion is to see whether it works in \Windows\ServiceProfiles\NetworkService\AppData\Roaming\SCP Secret Laboratory

It will need to be owned by NETWORK_SERVICE

I haven’t hosted one since testing your template. But the e-mail says it will be generated in your “config” folder.

That worked. The one thing that I didn’t think to try.

Glad it worked, but disappointing that what I was told by Northwood was wrong (they said that nothing relevant would be stored there when using the hosters method).

I guess for auto generation of the key it doesn’t particularly matter, but for cases like yours, when you are manually supplying the key, it does.

It should be simple for them to code a flag that just puts everything where told, rather than this messing about.

I will follow up with them.

I mean it’s fine but it is really annoying considering I asked if there was another place I could put the key due to the issue and I was told by multiple people no.

I’ve DM’d the CIO regardless