Satisfactory update 6 - can't connect and weird behavior

OS Name/Version: Ubuntu 20.04

Product Name/Version: AMP Release “Triton” v2.3.4.3, built 12/07/2022 13:00

Problem Description:
I tried to run satisfactory dedicated and it works well. Then I tried to change to experimental to run with update 6, hit update and start it again and then problems starts.
Ingame when I deleted server connection and created it again it’s not asking me anymore for claiming server and password settings and just let me in. Then I can’t create new game. Connection is impossible.

So I decided to delete instance and make it new again with normal settings (not experimental) and in my computer install normal client again.

But now I have error version mismatch. Game version 188609 and server version 195135

It seems like AMP keeps installing experimental version.
How I can go back to normal vesion? Deleting instance not working.

Steps to reproduce:

  • Create instance for satisfactory and connect with game client, create new game
  • Change build to experimental on AMP and game client (steam) - see can’t connect
  • Delete instance and create new for normal build
  • Reinstall game client to normal version

Actions taken to resolve so far:

I’m having the same problem.

The game doesn’t connect anymore, it worked normally.

If you’re switching to Experimental, ideally you want to make an entirely new instance and change it to Experimental before hitting update for the first time.

That’s exactly what I do. It seems that experimental isn’t working on dedicated server at all.
I also tried it on separate steamcmd (without AMP) and it works the same.

Today I see that experimental server crashing when someone trying to connect - there was some errors in log that server can’t find some game files but I can’t say that it’s the cause.

Anyways the problem that I’m unable to switch back to normal installation was still there (stop and delete instance, create new instance, check that there isn’t experimental on, update, start).

Today I solved it by completely remove amp from system, delete amp user, delete all associated files and install fresh AMP providing my licence key. I don’t want to play with experimental anymore because it looks like AMP somehow remember that option for future and there is no way back when I try it.

Can you dump all the information from the Support tab of your Satisfactory instance?

Did you set this up in your config file?

SteamCMD Branch


NOTE: You do not need a beta password to run season 6, just that (branch=“experimental”) line.