Rust update requires query port

OS Name/Version: Ubuntu 20.04 SERVER

Product Name/Version:
AMP Release “Halimede”

v2.4.1.2, built 21/12/2022 17:54

Problem Description: RUST server i have absolutly no way to define a query port in these settings for the gameserver which latest update to industrial requires server to have both a game port typically 28015 and a query port 28016 seperated but for some reason i cant figure out how to add this seperated port to the config its almost as if the amp instance hides the server.cfg file from the instance as i have cruised the ftp to find this particular file but i can not find it

Steps i have taken

cruised ftp looking for server config file

shut down deleted entire game server and instance tried to recreate, did not show up in the RUST window in the config

played with and tried to add port manually did not work

so now i contact support because this should be addressed

AMP doesn’t use a config file for Rust (or for most games for that matter) - it looks like the Rust module will need updating.

In the mean time, you should do the following:

  • In ADS, right click your Rust instance, select “Edit Port Bindings” and add the missing port manually.
  • In your rust instance configuration, go to Rust → Custom Startup Flags and add +server.queryport 28016

This will allow you to keep going in the mean time until the module is updated.

I have modified the title of the post to reflect the actual issue.

I have the same problem, I followed the instructions given in your guide but the server still doesn’t appear in the game list

1 Like

I too haven’t resolved this issue I run Garry’s mod and my sandbox appears in the server list but rust shows up as server unresponsive and when people click from outside like rust-servers dot net it directs them to IP:port and steam or other platforms can’t log them in this is really bad imagine I were to buy the enterprise license and sold these out to people bad for business

Have you checked your firewall rules?

I have checked my firewall rules I’m running a dedicated machine on a dedicated internet connection tied to no outside networks so at this time my modem is wide open and amp is taking care of opened ports for the instances and this wide open stuff still get the same result

Just realised you’re talking about a different game. Don’t thread hijack please, open a new post if it’s about a different game.

I am not talking about a different game Infact I started this thread I am referring to the game rust I am unable to get the query port to work in rust which this thread was originally created for, unable to make this port work doesn’t matter what I do all my security is down on my server and still can’t load the game through url for my friends to join they have to F1 to console from within the game and manually connect everytime because steam can’t populate the server details and auto connect them

Have you checked that ampinstmgr dumpfirewall (requires root) actually shows the query port you added to AMP listed?

i would like to know if the Rust Module is updated now.
For me its also not work for some reason.
Ports are open and the same server with my bat script starts normal.
Have added the ports as you discibed.
I also try finding the Rust module to fix it myself.
Where is this located ?
Greets Lemo

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.