Raspberry Pi 5 compatibility? CPx2 not working out of the box

I know the Raspberry Pi 5 has only just started shipping out, so I understand things may not work. I tried this as soon as I got it on the weekend, but no luck so far without making changes outside the installer.

OS Name/Version: Ubuntu 23.10 (Server)

Product Name/Version: v2.4.6.6, built 05/10/2023 12:01

Problem Description:
x86 (and x64) applications cannot be installed, at least those that require steamcmd. In short, the AMP installer does not appear to install the dependencies required for CPx2.

Initially, I tried installing AMP on Raspberry Pi OS “Bookworm” 64 bit and it did not ask about installing CPx2. I even tried the configureDarkMagicNew argument, and it seemed to compile it, but steamcmd would still not run. I did not check any further with this OS as the website recommended Ubuntu Server.

I installed Ubuntu Server 23.10 and followed the same steps, except it asked me if I wanted to install CPx2. The install finished very quick (too quick for a compile). But steamcmd would still not work. It said cannot execute binary file: Exec format error which would suggest no emulation.

I checked the initial getamp log it this is what it logged:

E: Unable to locate package libncurses5:armhf
Cloning into 'box86'...
Cloning into 'box64'...
/dev/fd/62: line 333: cmake: command not found
/dev/fd/62: line 334: make: command not found
/dev/fd/62: line 335: make: command not found
/dev/fd/62: line 341: cmake: command not found
/dev/fd/62: line 342: make: command not found
/dev/fd/62: line 343: make: command not found

I installed cmake and make, which then made it possible to build box64. This can be confirmed by checking the version:

root@raspberrypi:~# box64 --version
Dynarec for ARM64, with extension: ASIMD AES CRC32 PMULL ATOMICS PageSize:4096 Running on Cortex-A76 with 4 Cores
Params database has 30 entries
Box64 with Dynarec v0.2.5 12c40a5 built on Oct 24 2023 22:21:30

However, steamcmd would still not work as box86 was failing to build:

-- The C compiler identification is unknown
-- The ASM compiler identification is unknown
-- Didn't find assembler
CMake Error at CMakeLists.txt:83 (project):


  is not a full path and was not found in the PATH.

  Tell CMake where to find the compiler by setting either the environment
  variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to
  the compiler, or to the compiler name if it is in the PATH.

CMake Error at CMakeLists.txt:83 (project):
  No CMAKE_ASM_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "ASM" or the CMake cache entry CMAKE_ASM_COMPILER to the full path
  to the compiler, or to the compiler name if it is in the PATH.

I installed build-essential and arm-linux-gnueabihf-gcc and it appeared to compile box86. But attempts to run anything using it would result in cannot execute: required file not found.

I do not know if I missed anything, so I added armhf architecture (sudo dpkg --add-architecture armhf) installed both libc6:armhf and libstdc++6:armhf. After that, box86 compiled successfully and I could run steamcmd.

Steps to reproduce:

  • Write Ubuntu Server 23.10 image to microSD card or SSD (and insert/plug into device)
  • Download AMP installer and run as root
  • Answer “y” to CPx2
  • Setup as standalone controller and finish the AMP installation
  • Create instance for any x86(x64) that uses steamcmd
  • Attempt to download server

Actions taken to resolve so far:

  • Installed Ubuntu 23.10 (originally used Raspberry Pi OS “Bookworm” 64 bit)
  • Installed build-essential, cmake, make, gcc-arm-linux-gnueabihf, libc6:armhf and libstdc++6:armhf (including dependencies) and install CPx2 using configureDarkMagicNew argument

As it stands, the AMP installer appears to not work correctly with either Bookworm or Ubuntu server on Raspberry Pi 5. It is required to manually install packages using the package manager in order for the CPx2 (box86 and box64) to compile.

There are a few other issues, notably not being able to find libncurses5:armhf and that the adoptium depot returns a 404, but those can be looked at as separate issues if needed.

I may have missed a few details here and there, but I can investigate and provide full logs at request.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.