Project Zomboid Server suddenly not working anymore

OS Name/Version: Windows 10 Pro (64 Bit)

Product Name/Version: AMP Release "Triton", v20220711.2, built 11/07/2022 13:27,
AMP Release "Triton" v20220711.3, built 11/07/2022 15:13
& AMP Release "Triton" v2.3.4, built 16/06/2022 16:08

Problem Description:
When opening the instance and clicking on “update”, AMP gives me an error with the title “Could not complete action.” saying “The current module does not support updating the application.”. When clicking on “Start”, I get the error “Specified executable 'D:\AMPDatastore\Instances\ProjZombMods\GenericApplication\Application.exe does not exist.”, same title “Could not complete action.”.
This happened overnight, yesterday the server worked fine, therefore I don’t know what happened that changed this. Do I have to change something in the instances .json to fix this?

Actions taken to resolve so far:
Updated and reactivated all modules.

Nevermind, I fixed it through creating a new instance, copying the serverfiles over and transfering the instance-options manually.