Project Zomboid server fails to update or start

OS Name/Version: Windows 10

Product Name/Version: AMP Release “Deacdeus” v2.4.4 built 17.05/2023 17:54

Problem Description: I bought AMP to install and manage Project Zomboid servers. The issue I have is after initially installing AMP and following the provided tutorials for first time setup, then creating my PZ server instance, I updated the instance to make sure it had the latest version of the game files and it now seems to just hang on “Starting Project Zomboid…” and the server never starts. I have tried deleting the instance and starting from scratch, which failed. I then tried to completely uninstall AMP and reinstall it, followed by setting up a new server instance which again failed. I am unable to locate any error logs to share so I’m pretty much stuck with trying to solve the problem.
EDIT: To add a little more info, when I start the instance, CPU usage goes up to around 30% maximum and hangs around there for just a few seconds before going back down to 0%. Then I just have that loading bar forever saying it’s starting project zomboid.
Similar behaviour is observed when trying to update the instance to make sure I have the latest files and that they aren’t corrupt. It gets stuck on SteamCMD Download for a long time and then eventually it just stops with no confirmation of if it sucessfully updated or not.

Steps to reproduce:

I’m not even sure if this can be reproduced by anyone else. I only have the 1 server machine to try this on. I guess to reproduce it, just follow what I described I did in the problem description.

Actions taken to resolve so far: Full reinstall of both AMP as well as server instance. I double checked config files for the game server and everything seemed how it should be (I have experience running PZ Servers outside of AMP so I knew what I was looking at).

Can you install this specific version of the C++ runtime, reboot, then hit the update button in the instance for me?

I did as you asked. The update did the same as before, I’ll attach a screenshot of what it looked like before the status message just went away. I’ll also attach a screenshot of what it looks like when stuck on starting the instance. It’s currently been stuck for 5 minutes so far at the time of writing this.
Stuck on SteamCMD
For some reason I can’t attach 2 images, nor can I send a 2nd image seperately until someone else has replied…

Can you show me the console tab at that point?

To be sure it wasn’t an issue with previous installations have the requisite software for AMP, I uninstalled anythin g relevant and did fresh installs of it. It seems my instance now updates, although extremely slowly given my 1Gb connection. I verified the app updated successfully via the console window. However I have a new problem when trying to start the server. It asks for an admin password so I make one and then it asks me to confirm it and no matter how many times I try, it says wrong password. I even tried simply pressing enter for no password twice and it still said it was wrong lol.

Removed screenshot due to IP showing. I’ll edit it out and try sending it again.

Under Configuration > PZ Server Settings > Admin Password did you click the “Generate Password” button prior to starting the server?

Have you generated an admin password?

Under Configuration → PZ Server Settings - find the Admin Password setting and click “Generate”.

Or they just need to type it correctly in the console lol. See the last line in the screenshot. The admin password can be set via the console if it has not already been set

Try it yourself. I tried 4 times and it said wrong password every time upon trying to confirm what I just typed even with just 1 letter, can’t mess that up.

I’ve tried it many times, given I am one of the authors of the template.

But I did just install a new instance on a Win10 box for the sake of completeness. Entered Password123 twice in the console, all good.

So it is broken for me, for some reason. I’ve had way too many problems wit this, I really would just like a refund and I’ll go back to running my servers manually with batch files like I was before.

You’ve not answered the questions about whether you generated an admin password.

Make a new instance, manage it, hit update, generate a password, hit start.

Please actually respond to queries so we can sort this out for you rather than throwing your hands up at every minor obstacle. ‘Broken’ is meaningless. Lots of people run Zomboid in AMP without issue so its just a matter of making sure you’re using AMP properly.

I don’t even see PZ Server settings in configuration. I’m telling you it’s broken. Meaningless now?

You need to Start and then Manage the PZ Server instance first. Once youre inside the instance managing it, you should see Configuration > PZ Server Settings

Yep done all that already. It was already started when I couldn’t see it so I thought maybe I had to stop it first before I could make changes in case it was accessing files.

So what do you see when you manage the instance and open the configuration menu?

The same as the screenshot I sent above. I suppose I’ll try a full reinstall of the software and restart of the PC seeing as I’ve gotten different behaviour so far every time I’ve done that.

You need to slow down a bit because you’re getting in the wrong place.

When you create a new Zomboid instance, make sure the After Instance field is set to “Start Instance”. Once its created, double click to manage it. Then it update inside the instance to fetch the files, then generate the password, then start it.

I’ve just done all that exactly how you typed in then, in that order.
I’ll try a fresh start again after work. Hopefully I get it working then.

You might want to hop on Discord if you haven’t already - CubeCoders™ in the #project-zomboid channel - Sounds like we’re in different time zones so when you’re back from work you’ll have a better chance of getting a quick response, or someone who can walk through it with you 1:1. You’re of course welcome to keep running through here.