Problem installing ARK Survival Evolved

OS = AlmaLinux release 8.6 (Sky Tiger)

Running AMP Ver

Trying to install ARK Survival Evolved from the “Create Instance” button fails

Steps to reproduce:

  • Select Application: ARK: Survival Evolved
  • Friendly name: ARK
  • After Creation: Start Instance
  • Click on “Create Instance”

All appears ok and the status says “Running”. Double click the instance, and I get the status page that shows a “Start” and “Update” button. Pressing “Start” button causes the message “ARK could not be installed”. Also, a spinning progress pops up on the top right saying “Application State: Unable to run”.

Actions taken to resolve so far:

I tried the “Update” button with the same result.

Prior to all of the above, I performd a “yum update” and upgraded AMP (it was already on so no change there).

I stopped and restarted the instance and again, no change.

I looked through all of the ARK options in AMP and couldnt see anything wrong.

I’m running AMP direct (ie not under docker).

Do you have any suggestions on what might be going wrong ?

Please post the most recent logs of the instance

I decided my server needed a reinstall to make sure things were clean. After the install, I had a similar problem, but it was resolved when I performed the following

yum install glibc.i686 libstdc++.i686 ncurses-libs.i686 -y

After performing the above, I didn’t need to reboot, I just clicked “Start” and this time, things started happening. It took quite a while for the update to complete and also a while for Ark to start, but thats normal for Ark. I have since played a quick game on it and am in the process of loading another one, so all good now.