OVH s3 compatible services do not work with cloud backup, even with the region auth header

OS Name/Version:

Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-56-generic x86_64)

Product Name/Version: (Always use the full version number - not ‘Latest’)

AMP Release "Halimede"
v2.4.1.2, built 21/12/2022 17:54

Problem Description:

It seems the cloud backup s3 authentication region header option has no effect now, at least during my testing on OVH s3 compatible buckets, I tried SIX different endpoints, all gave the us-east-1 region error, the one it is currently set to should have it’s region flag set to… “bhs” if I recall (without quotes). I will include some images of the error

Steps to reproduce:

  • Freshly install or upgrade AMP, existing installs need the latest versions
  • Configure cloud backups to use OVH s3 compatible buckets
  • Set the required region auth header
  • Create a backup
  • Attempt to upload said backup. Should give region auth header error

Actions taken to resolve so far:

I have tried multiple forms of OVH s3 compatible services, all of them gave this error. I’m unsure of what the cause of this issue is. No matter what region I try to use, same error.

Also, I asked for help with this 10 days ago, and got ignored. So I am providing more details for you as I likely didn’t provide enough information or did it wrong, and because more details have made themselves known to me about this issue due to testing.

No cause can be found for this issue at this time. Have you tried connecting using the Amazon S3 command line tools? AMP does set the AuthenticationRegion as intended but I can’t speak for what the S3 library is doing under-the-hood.

I will try later, it could be a change in the library itself, or an issue with ovh, it may be a different header is needed