November 2022 Bedrock Update

OS Name/Version: Ubuntu 22.04.1 LTS

Product Name/Version: (Always use the full version number - not ‘Latest’)
AMP Release “Halimede” v2.4.0.10, built 2

Problem Description: I looked through the forum and have seen this question in various form and the answer seems to be to make sure amp is updated and it will pull down the latest bedrock version. I seem to be stuck on and client cannot connect saying cannot connect to outdated server.
I have tried every combination of shutting down instances and hitting the various update buttons and something seems to happen, but the window closes out and I’m still on the outdated version. I’m new to running game servers, but not other web based services and appreciate any input.

Steps to reproduce:

I note this in the logs: [APIService Warning] : tried to use session ID 5f944100-11dc-4718-80e7-6XXXXXXXXXXX8 - but no such ID exists while attempting to call GetUpdates

Actions taken to resolve so far: reboot server, update amp, hit various update buttons after stopping the instances. ran ampinstmgr --nocache upgradeall and rebooted, apt get update , apt get upgrade.

thank you for looking.

You say “the window closes out”… Do you mean the notification in the bottom right?

What version does it install on a fresh instance?