Moving Enshrouded server to Windows AMP

OS Name/Version: Windows 11 23H2
Product Name/Version: v2.4.8, built 29/01/2024 18:40
Problem Description: New Enshrouded server fails to start after attempting to move files from Nitrado Host.

[online] Server connected to Steam successfully
[online] Server is not VAC Secure!
[online] Server SteamId: XXXXXXXXXXXXXXXXXXX
[online] Public ipv4: 67.XXX.XXX.XX
[OnlineProviderSteam] 'Initialize' (up)!
[OnlineProviderSteam] 'JoinOrCreateGame' (up)!
[OnlineProviderSteam] 'SetLobbyData' (up)!
[OnlineProviderSteam] 'JoinLocalPlayers' (up)!
[OnlineProviderSteam] 'ConnectToPeers' (up)!
[OnlineProviderSteam] finished transition from 'Uninitialized' to 'InGame' (current='InGame')!
[Session] 'HostOnline' (up)!
[Session] finished transition from 'Lobby' to 'Host_Online' (current='Host_Online')!
[savedata] Could not load container with currupt data crc 0x32c62f8829a11c01 != 0x982e2ffdde85c287.
[savedata] Retry 2 operation on Container '3ad85aea'
[savedata] Could not load container with currupt data crc 0x32c62f8829a11c01 != 0x982e2ffdde85c287.

Steps to reproduce:

  • Step 1 - Create new Enshrouded AMP instance, all default options
  • Step 2 - Start instance, update server files
  • Step 3 - Copy server files from savegame directory from Nitrado to equivalent AMP dir

Actions taken to resolve so far:

I’ve successfully run Enshrouded servers in AMP, this is an attempt to get a Nitrado hosted server into AMP, so we do not lose our progress.

  • Created new instance/updated and tried to drop savegame folder into AMP - same crc error
  • Created new instance/updated, then started the server and replaced server files from savegame dir
  • Tried copying just the server file (3ad84aea), tired copying all three (3ad84aea, 3ad84aea.backup, 3ad84aea.journal)

So I guess my question or help needed here is, what is doing the crc check on the server file and is there a way to disable it for this particular instance?

Dumb! You can’t reply to your own thread until someone else has?!?! lol

Please help! :smiley:

Doing some googling I noticed people were having some success moving their local games to server hosting, etc… A few mental notes I made:

  • It appears as though the server file naming is different maybe depending on where it’s hosted? Locally, versus on a VM, versus in Windows? The people having success appeared to have different file names. My server file names are the same 3ad84aea on Nitrado and 3ad84aea on Windows/AMP.
  • Some people mentioned having _info files, which I’ve never seen … not sure if this is a local hosting thing?
  • Nobody is mentioning the .journal file … I’m wondering if this is something newly implemented during one of the recent patches to help with the saving/lost progress bug?

Anyways, I guess I’ll try out the Enshrouded discord to see if anyone’s attempted what I’m doing or has seen the crc check on the server file.

Thank you!

In AMPs file manager/SFTP you’ll have a numbered directory - that’ll contain the game server files. From there the directory structure should just match any other installation.

Thanks for the response!

Yes, I’ve been successful in figuring out the directory structure within AMP and I’m nearly certain I’ve found the relevant files (as much as we know about Enshrouded). From Nitrado all I really see and have access to is the .json config file (server name, password, etc.) and also the savegame folder with the main server file, the .backup file and the .journal file.

I’ve compared the server logs of my working AMP Enshrouded server and the one I’m trying to setup from the Nitrado copy. The one thing that stands out most to me is that AMP logs a crc error on the server file while attempting to load the container.

Could not load container with currupt data crc 0x32c62f8829a11c01 != 0x982e2ffdde85c287.

This server file(s) work fine on Nitrado and I’ve also tried copying multiple times. Is there an option hidden someplace within AMP to disable this check?

Thanks again!

How exactly did you copy the files over to AMP? Did you use AMPs SFTP or some other means?

FileZilla ftp from my gaming PC to Nitrado to grab the .json file and savegame folder.

Then just drag-and-drop from gaming PC > NAS > Windows AMP server > Enshrouded directory.

Side note, I’ve been successful migrating an ARK: SA server off Nitrado to AMP using the same method.

Dragging and dropping into AMPs directory structure in Windows will not work. You should use AMPs SFTP even on a local system to avoid damaging the permissions.

1 Like

Appreciate the response and I will definitely give that a go this afternoon, but to say that, “Dragging and dropping into AMPs directory structure in Windows will not work” is not accurate, as I’ve done exactly the same process I mentioned above to successfully move ARK: SA … worked first try.

More that it carries a high risk of problems due to the permissions not being right.

Copying the files directly from Nitrado (server powered off) to the AMP instance through winscp worked like a champ. Thank you for the help @Mike!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.