Missing persmisson for Unturned "Server Settings" tab

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Linux Ubuntu

Product Name/Version: AMP Release “Triton” v2.3.2.12

Problem Description:

I created a user for a sub-admin which maintains the Unturned Instance. I gave him the appropriate permissions in a seperate role, but he cannot access/see the “server settings” tab in the Unturned instance (see screenshot below). I tried giving him all permissions and even assigning the super-admin role neither helped, not even after logging in/out, clearing the cache.


Steps to reproduce:

  • Step 1 Create Unturned instance
  • Step 2 Create role “sub-admin” and assign every permission to allowed
  • Step 3 Create user and assign role “sub-admin”

Actions taken to resolve so far: Tried clearing browser cache, logging in and out, recreating instance, assigning “Super Admin” role.

Have they got perms under Settings/Meta/GenericModule?

Yes but they aren’t working, even if they are granted the user doesn’t see them.