Minecraft Server "Failed to verify username!"

OS Name/Version:

Ubuntu 20.04.4 LTS

Product Name/Version: (Always use the full version number - not ‘Latest’)

AMP Release "Triton" v2.3.3.4

Problem Description:

My Friends cannot join without getting the Error “Failed to verify username!” in the console. (can join other servers)
The Server mysteriously works for me, but only with my main Account.
If I use a Hacked client with an Alt Account I get the same error (works on other servers)

Steps to reproduce:

(Not known)
Problem appeared on fresh install

Actions taken to resolve so far:

-Checked DNS Resolution of Host and Docker
-Checked Ping (Host & Docker)
-Changed Instance from Host to Docker version
-Created New Instance
-Used Different Version and Distribution
-Created a Server on my Local Computer (Worked like a charm)
-Reinstalled my friends Minecraft client (tried MS Store and Installer)
-My Friend Re-Booted and Re-Logged
-Used my Public IP Instead of Domain
-Checked Firewall Logs (temporarily opened completely → did not help)

Not an AMP issue. If it works with some users but not others it’s stricly handled by Microsoft. AMP is entirely uninvolved with anything that happens in-game or anything to do with the verification of users.

I can understand you standpoint.
But everything works from the side Mojang and/or Microsoft.
Only when I use AMP the server does not accept NEW players

I’ve now also confirmed that running a Minecraft server on the same server as AMP, does Work as expected.


Turns out, disabling “Disallow proxied connections” fixes the problem.
It works now but I’m curious on what basis AMP blocked all outside connections? :thinking:
Thanks in advance :grin:

AMP does not block anything. The “Disallow proxied connections” setting is part of the Minecraft server itself. Like I said, none of this is anything to do with AMP :slight_smile:

@Leandro_Klaus, thanks for the update. I’m experiencing the same issue. I’m running AMP behind a reverse proxy.

@Mike, this might be a rudimentary question but what is the recommended way to edit the server.properties file? When I try to edit the file directly it gets reverted back.

If you edit it manually you must right click it and import it using AMPs file manager.

Thanks for your quick reply.

I have created an additional server.properties file with another name. When I right click it and select Import Configuration, the server.properties hasn’t changed. The
prevent-proxy-connections=true property is still set to true.

That’s not how you use it. You edit the original one and apply your changes there, and import that.

I don’t know what I’m doing wrong? Here is what I have tried, but without any luck. The setting keep reverting to TRUE instead of FALSE.

  1. From the Main Menu I go to File Manager
  2. Navigate to the specific Minecraft Instance in the file manager and double click the server.properties file
  3. Change “prevent-proxy-connections=true” to “prevent-proxy-connections=false”
  4. Click the green save button
  5. Click on Instances in the left navigation bar
  6. Right click on the Minecraft instance and click on Manage
  7. Click on File Manager under this instance
  8. Right-click on the server.properties file and selecting “Import Configuration”
  9. I get Import Complete windows with the following message: “34 entrties were successfully imported. See advanced details for information on any failures.”

Advanved Details:

The following lines could not be imported:
resource-pack-prompt={"text"\:"A resource pack is required to connect to this server.","color"\:"red"}

Any help would be highly appreciated.

I found the solution on changing the specific prevent-proxy setting. I missed the toggle button in the management interface “Disallow proxied connections”. I think this was the reason why I couldn’t change the proxy property in the settings.property file.

1 Like

Turning “disallow proxied connections” fixed this issue for me! Strangely enough it was only happen to devices that we connecting to the same local network, external devices were fine.

Sorry - where is this proxied connections setting found? I feel like I’ve looked everywhere!

Use the search bar at the top right in the instance :slight_smile:

1 Like

There’s a search bar!!! :blush:

Had this issue also. Was pulling out what was left of my hair trying to figure it out. Public IP worked fine but got the same error when trying to connect to my MC server with a private IP. What confused me is that I am not behind a proxy or anything like that.