Minecraft Java with Geyser/floodgate plugin

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Ubuntu 22.04

Product Name/Version: AMP Release “Decadeus” v2.4.2, built 21/02/2023 11:49

Problem Description:
Steps to reproduce:

  • install Java Minecraft Paper
  • Download Geyser and Floodgate from Jenkins and put in plugins folder
  • add custom port 19132 to instance

output of consoles shows plugin loaded :


``19:56:48 Building unoptimized datafixer
19:56:51 Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
19:56:55 Loaded 7 recipes
19:56:57 Starting minecraft server version 1.19.3
Loading properties
This server is running Paper version git-Paper-446 (MC: 1.19.3) (Implementing API version 1.19.3-R0.1-SNAPSHOT) (Git: 4e99466)
Server Ping Player Sample Count: 12
Using 4 threads for Netty based IO
[ChunkTaskScheduler]: Chunk system is using 1 I/O threads, 1 worker threads, and gen parallelism of 1 threads
19:56:58 Default game type: SURVIVAL
Generating keypair
Starting Minecraft server on
Using epoll channel type
Paper: Using libdeflate (Linux x86_64) compression from Velocity.
Paper: Using OpenSSL 3.0.x (Linux x86_64) cipher from Velocity.
19:56:59 [floodgate]: Loading server plugin floodgate v2.2.2-SNAPSHOT (b77-089b9a7)
19:57:01 [floodgate]: Took 1,262ms to boot Floodgate
[Geyser-Spigot]: Loading server plugin Geyser-Spigot v2.1.0-SNAPSHOT
19:57:02 [Geyser-Spigot]: Loading extensions...
[Geyser-Spigot]: Loaded 0 extension(s)
Server permissions file permissions.yml is empty, ignoring it
Preparing level "world"
19:57:04 Preparing start region for dimension minecraft:overworld
Time elapsed: 403 ms
Preparing start region for dimension minecraft:the_nether
Time elapsed: 123 ms
Preparing start region for dimension minecraft:the_end
Time elapsed: 88 ms
[floodgate]: Enabling floodgate v2.2.2-SNAPSHOT (b77-089b9a7)
19:57:06 [Geyser-Spigot]: Enabling Geyser-Spigot v2.1.0-SNAPSHOT
[Geyser-Spigot]: ******************************************
[Geyser-Spigot]: Loading Geyser version 2.1.0-SNAPSHOT (git-master-2f23e5c)
[Geyser-Spigot]: ******************************************
19:57:18 [Geyser-Spigot]: Started Geyser on
[Geyser-Spigot]: Done (12.06s)! Run /geyser help for help!
19:57:19 Running delayed init tasks
Done (22.025s)! For help, type "help"
Timings Reset```

I can connect with Java client but not with Bedrock client. If I install Bedrock instance clients can connect to the instance so not a firewall thing.
1 Like

Did you add the custom port as UDP? Are you trying to connect locally or via public IP?

I tried both, adding the port 19132 as UDP and UDP + TCP. I tried to connect directy and through domainname forwarded by pfsense firewall to AMP server.

Setting up a bedrock server as instance works, adding the plugins to java Paper server and adding a custom port doesn’t.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.