Minecraft Bedrock unable to get latest version 1.20

OS Name/Version: Ubuntu 22
Product : AMP ‘Decadeus’ v2.4.5.0 (Mainline)
Application : Minecraft
Module : MinecraftModule


Tried to install my Minecraft Bedrock server today but it’s staying at version 1.19.72 and the latest is 1.20. A person on another topic mentioned that the issue may be that MS is blocking the version check queries again…

[03:00:52] [Logger Warning]       : Unable to get Bedrock version data from https://minecraft.net/en-us/download/server/bedrock
[03:00:52] [Core Error]           : TaskCanceledException
[03:00:52] [Logger Error]         : [0] (TaskCanceledException) : The operation was canceled.
[03:00:52] [Core Error]           :   at MinecraftModule.UpdateManager.GetBedrockVersion () 
[03:00:52] [Core Error]           : ObjectDisposedException
[03:00:52] [Logger Error]         : [1] (ObjectDisposedException) : Cannot access a disposed object. Object name: 'MobileAuthenticatedStream'.
[03:00:52] [Core Error]           :   at Net.Http.HttpConnection.FillAsync () at Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync (Boolean foldedHeadersAllowed) 
[03:00:52] [Minecraft Info]       : Trying first Bedrock info fallback...
[03:00:57] [Minecraft Info]       : Using fallback bedrock version data...
[03:00:57] [Logger Info]          : Latest Bedrock version:

Steps to reproduce:

  • Step 1 : Install new instance of Minecraft Bedrock version
  • Step 2 : Update and start server
  • Step 3 : Server start in 1.19.72

Anyone else having issues getting to 1.20 ?

Can you access the download link from the server? Also, you have to restart the instance to get the latest version.

So I tried directly from the docker container but the minecraft.net address does not solve, nor even me from my PC directly.

However, I noticed that the url by going directly to the minecraft site is redirected to www.minecraft.net (this one resolves well from the container).

Would Microsoft have made any changes to the minecraft site? I don’t really know how CubeCoders retrieves version information from bedrocks servers.

Finally, here it may be a track. Would there be a somewhat temporary solution like to manage to download the latest version of the bedrock server on my side and then give it to my cubecoders instance?

Usually that’s a network related issue like your IP is blocked by Microsoft for their site.

You can definitely upload the files yourself. Your best bet is using SFTP using the icon in the top right of the File Manager in the AMP GUI.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.