Minecraft bedrock server not up to date

OS Name/Version: Ubuntu 20.04.3 LTS

Product Name/Version: Currently running version 2.3.2

Problem Description:

I’m hosting a little Minecraft bedrock server and people can’t play on it anymore for over a week because it’s out of date. The server is running the Bedrock (Official Pocket/Win10 server) and is on Version The clients are automatically updated to version 1.18.10 and can’t be downgraded.
Is there any way that I can update this version by hand to the latest bedrock version or are you bringing out the update to bedrock server soon.

I tried to update it with the update option but it stays on version
Also tried the other server type: Minecraft Pocket/Windows 10 Edition (Experimental) and that one is up to date but the clients lose there inventory and other progress so that’s not an option.

Thank you

unable to reproduce. I’m able to update it

Try restarting AMP and hitting update again. This will make AMP re-check for updates.

Updated amp server to the latest version today and upgraded all instances. Now the new update is installed on the bedrock server.