Minecraft 1.18.2 Forge Server setup

OS Name/Version: Windows 10

Product Name/Version: Minecraft 1.18.2 Forge Server

Problem Description: I cannot start a forge server. I whipped the folder multiple times. Hit start and it refuses to start the server in the instance.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1
  • Step 2
  • Step 3

Actions taken to resolve so far: I have tried manually starting the server, creating a separate folder with a new install and even on a second desktop.

Make sure that in the AMP web page you are:
creating a new instance, that is of the application type “minecraft java”
once the instance has started click manage,
click configuration then proceed to server settings,
here you will select the server type, make sure you select Forge,
after the settings automatically save click download/update,
wait until the notification goes away, it is installing the latest version of forge,
after that has completed you may select your release stream, if you are running a modpack I highly recommend using “specific version”,
then select your Forge Version, make sure it matched what client you want to use to connect with,
I would then click download / update again and let it download that version of forge that you specified
after that has completed if you are running a specific modpack, make sure you got the server jar file and upload that via the file manager,
once that has been uploaded or if you just want to play vanilla forge go back to server settings and click “scan for new jars”,
once that is done you may select it from the dropdown box
if you did all that without an error you would have successfully installed a forge server
if you run into a network problem it is likely your firewall either on the server or router, if you run into critical errors it could be because you do not have the right version of java installed, try updating your system.

Got it up and running. Had to pull the Forge server file out of the subfolder and introduce it to the root folder. Thank you!

No problem, Its a pleasure to help.

I’d like to comment that installing and selecting jdk-17 was necessary in the configuration for the program to start as listed above for the vanilla version but will not run the forge version. I’ve tried both the server and universal listing that were downloaded.

Can you provide any error messages or log files? Because for me it’s working (I checked it today). As you can see in the pictures below. I can only help you when I know where to start :wink: