Issue with backups in v2.4.0.4

OS Name/Version: Ubuntu 22.04

Product Name/Version: (Always use the full version number - not ‘Latest’) AMP v2.4.0.4

Problem Description: Trying to take a backup of a Minecraft instance, but the backup never completes. Popup notification shows up, progress bar continually loads, but it never goes away and new backup file isn’t created. First noticed when logging into the instance that it was showing up, from a scheduled backup that would have occurred 7 hours earlier.

Steps to reproduce:

  • Click on “Backups”
  • Try to create a backup.

Actions taken to resolve so far:

Restarted instance to see if that would help. Notification was gone, but no new backup showed in list. Attempted a manual backup, notification still hung. Ran the ampinstmgr --nocache upgradeall command after I’d read there was an issue with the latest update, but that didn’t fix this issue when attempting another backup. Tried stopping application entirely in case there was an issue with the backup being taken while running, did not fix the issue. The notification appears to be stuck on “Building File List…” Wondered if this might be a return of the bug where notifications simply wouldn’t go away, but continuing to try to make backups, refreshing page and restarting instance, never shows a new backup in the list.

Have you checked the logs?

Could you guide me to where to find them? The logs under “files” for that instance are just the console output, and the backup events don’t appear to be listed there.

Right click the instance → View Logs.

You may also want to enable debug mode: Diagnosing AMP issues · CubeCoders/AMP Wiki · GitHub

The only mention of backups in the log is:

[03:00:00] [FileBackup Activity]  : Creating Backup: Scheduled Backup
[03:00:00] [FileBackup Info]      : Cycling Backups...
[03:00:00] [FileBackup Activity]  : Deleting Backup Scheduled Backup (Automatic Operation)

Even when I manually take one it lists that similarly:

[16:38:54] [FileBackup:skorpeyon Activity] : Creating Backup: test
[16:38:54] [FileBackup:skorpeyon Info] : Cycling Backups...
[16:38:54] [FileBackup:skorpeyon Activity] : Deleting Backup Scheduled Backup (Automatic Operation)

Tried the debug mode suggestion as well, but only received this additional information:

[16:41:41] [FileBackup:skorpeyon Activity] : Creating Backup: test
[16:41:41] [FileBackup:skorpeyon Debug] : Building file list...
[16:41:41] [FileBackup:skorpeyon Debug] : File list built: 1910 files totaling 2528MB
[16:41:41] [FileBackup:skorpeyon Debug] : Checking cycling requirements...
[16:41:41] [FileBackup:skorpeyon Info] : Cycling Backups...
[16:41:41] [FileBackup:skorpeyon Activity] : Deleting Backup Scheduled Backup (Automatic Operation)

Guessing that the process is failing to delete the backup it needs to, perhaps?

It might be failing to delete the backup needed. I’ll have to get back to you on this.

Sorry, I think I may have found the problem. Decided to try to delete the backup manually from within AMP, got a “permission denied” error. Then decided to log in and delete it manually via ssh on the server. Changed user to the AMP user, and still got a “permission denied” error. Had the backups stored on an external drive so as not to take up too much space on my main hard drive. Basically, it appears that the permissions had somehow changed, perhaps with an Ubuntu update. Having some issues fixing it, but It’s nothing to do with AMP, apparently. Might consider some kind of error message if a backup can’t be completed due to permission errors, maybe? But regardless, my problem should be fixed once I fix that. Appreciate the help.

Edited to update: This was, in fact, the issue, and I completely read my backup dates wrong, this had been going on for a month, not a day, so at some point something got screwed up with my permissions. Fixing that did fix this.