Instance of V-Rising Server corrupting itself?

OS Name/Version: Windows Server 2022

Product Name/Version: AMP 2.3.4 (though the issue was on the version before this one

Problem Description:

I had been running my AMP server fine for the past couple of months, with no issues. As part of the reorganization I have been doing to have the servers running under one domain name, I added the server to a Cloudflare Tunnel, along with our other servers. When this happened I didn’t experience any issues then. I even played that night on the V-Rising server I was hosting and no issues happened to me.

However, this past Tuesday, June 14, I received a notification from one of my users, saying the V-Rising server was down. I went to the game and it was down alright. So I went into the server instance and took a look, the server was still running and I was able to check out the console logs, nothing really stood out to me as being off. At this point, I had written in the V-Rising Channel in discord that I had this issue where one of the servers was completely offline. I provided that day the log file below:


At this point, I tried creating a new instance to spin a new V-Rising Server but when I tried to create the instance I got this message from AMP:

Unable to complete the task
This task could not be completed: Create instance - V Rising - State: 3.
The core archive failed to download or unpack```

@IceofWraith commented asking me if I was sure I didn't have a network issue.  and I responded that I was sure I wasn't because I had other servers running fine that were under the tunnel.  He suggested deleting the cached zips in the datastore, so I did, restarted everything and the issue continued.

So I scaled back to the main server of Windows 2022, checked my network, did some tests, and the network connection and all the internal routing were working.  I patched the Windows Server, rebooted it, and launched AMP, then manually launched the V-Rising server and it continued to have the same issue.

*I remembered that during the setup of the tunnel I had tried to change the port AMP was using to display itself on the browser, from port 8088 to port 8600.  AMP didn't like that at all when I tried it and I had to run the rebind command to reset the ports like they were original.*

I thought this previous event had screwed something up in AMP  so I went ahead and as a last measure, I took the server out of the tunnel, uninstalled cloudflared, and rebooted the whole windows server.

Rinse and repeat the issue persisted exactly as I reported, except that now I had a new error:

Failed to login into a remote instance

The login server is unreachable. Verify that the auth server URL in this instance’s config file is valid. This is the ‘Login.AuthServerURL’ line in AMPConfig.conf for this instance.```

In Login.AuthServerURL says, so why is it can’t reach itself? I flushed the virtual nic card and I tried again, but AMP is flogged.

At this point, I made a backup of the V-Rising Server, uninstalled AMP, and rebooted the windows server, then I had to remove AMp from the registry because every time I tried to install it was using things that were from the previous install.

After I was able to finally uninstall all of AMP, I tried to re-install it back as I had it originally. I don’t know if the AMP installer had some changes to it, but even if I chose a different path to install it, (I wanted to install it so both AMP and AMPDatastore were under the same sub folder, AMP had other ideas, so I just let amp install itself on the HDD I wanted and let it install on the folders it wanted…

I then was able to install a fresh instance for V-Rising, installed and updated the server, launched it, stopped it, configured it how I had it last time, then imported the world I had backed up and it finally went up and I could see it from the game server listing. I logged into it and played a bit to make sure it was working fine. I thought this was the end of it.

But then yesterday I got notified that the v-rising server had crashed again because you couldn’t log into it. I launched my game and tested that and sure thing the server was unreachable again. This was at 3 AM.

I commented this time in #tech-support that sometime between 3 AM and last night the server crashed again, same issues. I tried to upload the AMP logs to discord but they were too big so I had to .7z and upload them that way.

I wouldn’t know how to reproduce it other than reinstalling everything all over again.

I was able to add the last log to a GithubGist (I think I almost crashed the internet ) :
I had to take down that link because you can’t make a post with more than two links when you are a new user on the forums.

To see my logs you can download them from here:

Hopefully, someone can help me because I can’t figure out why this is happening. At least the players are being patient.

\TexasBloodRising\v-rising\1829350\save-data\Saves\v1\world1\AutoSave_18377\" is denied.

I see this listed many times for a lot of the autosave folders. It looks like you might have permission issues. You should upload the files using the File Manager or SFTP if you didn’t already. If you did, reach out to the V Rising Discord because that’s a game issue, not AMP.

This problem used to be an amp problem, and after I wiped amp and reinstalled it, it converted to a rising problem. I still want to know why AMP chocked and the only solution was to uninstall the whole thing.

The suggestion you bring, I am going to try it, because that is something I haven’t done. But how do the files lose their permissions if the server has been running since well you know since and this is the first time it ever happened.

What permissions does amp need? Should I delete the world and recover the world through a backup using the internal File Manager or SFTP?

Just really curious as to why it screwed up.

Nobody knows why AMP had issues but from our discussion before it looked like a routing issue of some sort. I remember there was more to it than what you listed here from our DMs. Unfortunately, since you’ve removed all traces of it there’s no possible way to tell. As Mike will say “Reinstalling is never the right thing to do”. Lol

For completeness, copying the world folder through the browser File Manager resolved the errors.