Instance is not listening on all IP's even though it shows bound to

OS Name/Version: Ubuntu 22.04.1 LTS

Product Name/Version: AMP

Problem Description:

Many instances do not appear to be binding to all IP addresses assigned to eth0 even though they show in netstat

Steps to reproduce:

  1. Added additional public WAN IP’s to eth0
  2. Configured firewall to use new WAN IP’s
  3. Configured AMP control panel to use public IP for application instances and docker external IP
  4. Set default gateway to use public IP range
  5. Restarted AMP server

Actions taken to resolve so far:

Testing with Minecraft Bedrock instance (v1.19.51). Bedrock appears to bind to all IP’s using & However, these ports are only responding on the primary IP.

Not sure if I have an issue or not. Several instances show they are bound to but they are not responding on all IP’s on eth0. Only the first IP for eth0 is being used.

The only instances that I can get on a different static IP are the Ark Instances where I can adjust the binding in the server settings. What’s odd is that bindings don’t seem to work on these other static IP’s…

Not all game servers allow you to select the IP. Some just “guess” which IP should be used which is annoying.

That being said… Minecraft isn’t one of those. Can you verify in ADS what you have setup under the Configuration->Networking Default Application IP Binding?

There is no network section, but just Server settings. It has the option to bind to server address which I have set to a public IP, but its just ignoring the settings and binds to

The networking tab is under ADS, not inside the Minecraft instance.