I am working on my server for the last 3 days but I can't resolve this problem

OS Name/Version:
Debian 11 with Game Panel

Product Name/Version: AMP Release “Decadeus”
v2.4.4, built 17/05/2023 17:54

Problem Description: I have tried installing my modpack in the file manager but every time I want to start the server it says that it cannot be run and I need to check the console for errors so I did some research but I just couldn’t figure out the cause of the problem I’m using JDK 8 for minecraft version 1.12.2 ( I will upload a picture of my filemanager and paste in the consoles error

A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:568)
at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)
at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)
Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')
at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
... 6 more

Steps to reproduce:

  • Step 1 Install the modpack
  • Step 2 Choose said forge version
  • Step 3 Try to run server

Actions taken to resolve so far: I have tried placing the files in different folders under different names and tried to use different java versions.

Looks like the wrong java version is selected. Check what version your server needs and that this is the version selected in AMPs settings.

I read that 1.12.2 runs on Java 8 and I only have these options
or isn’t JDK 8 the same as Java 8?

Try changing it to another version then back to 8.

there’s no wayyyyyy thank you!!!
One last question. Should I Give My server the full 8Gigs of RAM or sould I leave a little excess

Assuming nothing else is on it, leave at least 512MB for the OS.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.