How to properly format Storage.StorePath to a network mounted drive

OS Name/Version: windows 11

Product Name/Version: 2.3.2

Problem Description:

what is the proper format for Storage.StorePath?
I have tried
/z/mc01 this just puts it in the C drive under a folder called Z
/z:/mc01 causes the instance to crash
Z:\mc01\ (and every other combination of this) causes: Unable to start backup

the drive path is “Z:\mc01” what is the format I need to make it back up to that?

also random suggestion, have you ever thought about implementing OneDrive or Google Drive backups in to amp. for easy and safe backups.

[11:17:07] [APIService:admin Warning] : Returned exception from API call LocalFileBackupPlugin/TakeBackup
[11:17:07] [APIService:admin Error] : DirectoryNotFoundException
[11:17:07] [APIService:admin Error] : [0] (DirectoryNotFoundException) : Could not find a part of the path 'Z:\mc01\'.
[11:17:07] [APIService:admin Error] :    at IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost)
   at IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
   at LocalFileBackupPlugin.BackupProvider.TakeBackup(BackupManifest manifest)
   at GSMyAdmin.WebServer.WebAttributes.InvokeMethod(String MethodName, JObject Data, IHttpRequest request, IWebSession Session, WebMethodsBase MethodsClass, String RawRequest)
   at GSMyAdmin.WebServer.APIService.InvokeAPI(IHttpRequest request, IWebSession Session, JObject Data, String RequestModule, String RequestMethod, String RawRequest)

It needs to be a UNC path - \\server\\share\directory

12:41:33] [System:admin Activity] : Creating Backup: 123
[12:41:33] [APIService:admin Warning] : Access denied: Access to the path ‘\192.168.1.122\PCs-Backups\AMP\mc01’ is denied. (Origin: 127.0.0.1:49172)

that seems more promising but how would I go about giving it permissions?
do I need to give the amp user in Windows permissions(if so how?) or do I need to give everybody permissions on the NAS?

edit: just tried to use the public folder and that doesn’t work either
[APIService:admin Warning] : Access denied: Access to the path ‘\192.168.1.122\Public\AMP’ is denied. (Origin: 127.0.0.1:49500)