How to add `ownerid` to Rust Dedicated Server - the users.cfg way

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Decadeus’ v2.4.6.0 (Mainline)
Virtualization Docker
Application Rust Dedicated Server
Module RustModule
Running in Container Yes
Current State Ready

Problem Description


Was trying to add an owner id to a Rust server.
Some posts suggest two ways to do it:

  • via RCON App command
  • via updating the users.cfg file

So here I tried the file way:

  • written ownerid 76561198123456789 "TomSmith" "" to /AMP/rust/258000/server/my_server_identity/cfg/users.cfg, via AMP web page’s File Manager.
  • restart the Rust Instance
    However, it won’t work. The file file will be back to empty after the restart, plus, in the game, F1Weapon → $AnyWeapon ARM won’t add it to the inventory.

Could you please advise how to do the file way correctly?

Reproduction Steps

  • add “ownserid a-steam64-id steam-user reason-to-add” to /AMP/rust/258000/server/my_server_identity/cfg\users.cfg
  • click “save”
  • get into AMP’s docker container, and echo the cfg file, it should it is been writtern.
  • restart the Rust Instance from AMP
  • The cfg file is still empty.

Put quotes around the steam id

Hi Greelan,


Tried ownerid "76561198123456789" "TomSmith" "reason-to-add", still, the file will back to empty after restart the instance.


Tried get into its container via docker exec -it amp-rust-container bash, then edit the file with the content directly, this leads to the same result after the restart.
The commands for the editing:

root@rs:/# echo "ownerid \"76561198123456789\" \"TomSmith\" \"some-reasons\"" > /AMP/rust/258550/server/my_server_identity/cfg/users.cfg
root@rs:/# cat /AMP/rust/258000/server/my_server_identity/cfg/users.cfg
ownerid "76561198123456789" "TomSmith" "some-reasons"

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.