Gmod server refuses to update

OS Name/Version: Linux/Ubuntu 20.04…?

Product Name/Version: AMP Release “Triton” v2.3.4

Problem Description: Garry’s mod will not update. I’m attempting to use the “update” button in-console, however it asks for my login info. AFAIK Gmod usually updates anonymously?? When I do enter the username and pass it askes for my Steam Guard. This is where I get stuck again as it denys my Steam Guard key, despite it being the one from my app on my acct… :confused:

Steps to reproduce:

  • Use the “update” button
  • Enter User/pass when prompted
  • Enter steam guard key when prompted
  • (Profit)

Actions taken to resolve so far:
I have:

  • Made sure AMP is up to date
  • Done extensive research regarding this topic on google
  • Searched this forum for similar issues

Thanks for help in advance. My messages kept getting buried in Discord and its very frustrating… haha

Can you right click the instance and View Logs, then share the latest here where you tried to update?

I forgot the logs could be accessed that way! Either way, this is all I have:

[11:45:19] [API:justin10023 Activity] : Updating the application.
[11:45:54] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user justin10023 from
[11:45:56] [RemoteAMPAuth:Anonymous Activity] : Authentication success

It’s not amp itself having trouble I think, it’s how Gmod and Amp connect. The instance is on the latest version, but Gmod is not. Just to clarify.

Hmm… That doesn’t seem to show what you’re referring to unless I’m misunderstanding the issue. Can you share the entire log?

Can do! Had to censor some login and IP stuff.

Pastebin link


Try taking the workshop item out.

You mean workshop ID 2658913429? In the steamcmd settings or source server settings?

Looks like it’s trying to update that from Configuration->SteamCMD and Updates. I’m curious if that’s prompting the login prompt.

Holy crap I think that worked! Gonna test gmod to see if it truly updated.

Edit: Solved! Thank you!