Glibc key expiration - known fix not resolving issue

Hi, I am running Windows 11 on a 64-bit operating system, and attempting to fix a server error on a server that I manage; using PuTTY to gain SSH access.

I have been receiving the following server log error:
```/home/amp/.ampdata/instances/KingdomMerc01/./Minecraft/bedrock_server: /lib/x86_64-linux-gnu/ version `GLIBC_2.29’ not found (required by /home/amp/.ampdata/instances/KingdomMerc01/./Minecraft/bedrock_server)

Running the command ldd-version in ubuntu is showing me that I am running Glibc version 2.8. I ran root command sudo apt update to update, which indicated there was an expired key to access the glibc file; This was a known cubecoders issue, and they provided a fix key (Invalid signature - #2 by Greelan). I downloaded the fix, and deleted the old key, but now the system is returning a NO PUBKEY error:

`The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 33FB60CD1A773489

Glibc is still showing as version 2.28, and I still can’t update the file. Do you have any advice? Everyone who ran the code that went out for the expired key was able to run the code without any issues, and all the threads I’ve seen were closed out without experiencing this issue that I am.

Actions taken to resolve so far: Attempted sudo apt update, ran code to fix known issue, deleted expired key from directory

This isn’t anything to do with an expired key - the problem here is you’re using a distro that is too old for AMP. My guess is that you’re running Ubuntu 18.04 on the server.

Dang, and here I thought I’d solved it :rofl:. So do I need to update Ubuntu then?

Assuming that you are indeed using 18.04, yes - 20.04 is the minimum supported version now.

So, and this is a totally newb question, but in the terminal when I run sudo apt-get update I am still getting an error message, although this one is a 503 server error. Do you have a recommendation for dealing with that? Thanks so much for your advice, I appreciate it a lot

That’s pretty vague, show actual output.

To upgrade your LTS version, see here.

Fair enough, this is the output when I run sudo apt update:
Screenshot (10)

The old Adoptium repo is gradually being phased out and they are deliberately having outages to prompt people to move to the new repo. Shouldn’t stop you from upgrading your distro

Woof. So what does the issue look like then? I get this whenever I run the command to upgrade my distro.

Remove that repo in /etc/apt/sources.d/ then

Hi Mike - I used the advise of a user below to update my distro. I am still getting a notice about an expired key even after upgrading and running the fix I linked in my post. Could I have some other problem?

So actually I’ve got the same problem with that key. I already updated it

wget -O /usr/share/keyrings/

But unfortunally this error still exists. Since I’m on a supported version of Debian that error shouldn’t exist, so hopefully somebody knows an answer that will get this repo working again.

getamp addRepo did the thing and problem solved

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.