Generic Module new configuration

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version:

Ubuntu 22.04.1 LTS

Product Name/Version: (Always use the full version number - not ‘Latest’)

[Info] AMP Instance Manager v2.4.1.2 built 21/12/2022 17:55
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV

Problem Description:

I wanted to make a custom config for a game(Killing Floor2 because the existing one kinda barebone and multiple thing is hardcoded or some feature is missing) i tried 3 different way but none of showed up in the Instance manager even with multiple AMP restart or full server reboot.

1. I made a full copy from the default one and edited all the stuff in it even the name.

2. I tried using AMP Configuration Generator.

3. I did also upload my own github the config file i added to AMP my github so i can fetch from there.

None of the method worked. I dont see my config Name in the instance manager.
The main issue even the config file is exist in the GenericTemplates folder i dont see in the AMP Instance manager.

Steps to reproduce:

  • Step 1
  • Step 2
  • Step 3

Actions taken to resolve so far:

Here’s the guide on how to properly add templates to your install of AMP. I’m the one who put together the original KF2 template, so let me know if you need any more help.

1 Like

Seems i forgote including manifest.json in my repo :sweat_smile: