Friends unable to join Satisfactory dedicated server

OS Name/Version: Windows 10 Pro 21H2

Product Name/Version: AMP Release “Triton” v2.3.4, built 16/06/2022 16:08

Problem Description: After starting a new Satisfactory instance with AMP, I am able to join my server locally, however, my two friends are both unable to join. I am using the game from the Epic Games launcher and they are connecting through Steam. They can see that the game is online and it shows the correct information (session name, current milestone, etc.) when added in Server Manager on the Satisfactory menu. When they click Join Game this error comes up:

ConnectionTimedOut

I also see in the console whenever they attempt to connect. I also see where it says, “Try running with -NOSTEAM on the cmdline to disable.” however I’m not sure where to add the command line argument.

Here’s my latest log: https://pastebin.com/7W0NejUT

Steps to reproduce:

  • Step 1 Start a new Satisfactory Instance in AMP
  • Step 2 Make sure ports are forwarded correctly
  • Step 3 Attempt to connect to game outside of local network

Actions taken to resolve so far:

  • Ensure I am able to connect to the server on my machine - no problems locally.
  • Made sure the correct ports are open on my router: 7777, 15000, 15777
  • Disabled Windows firewall for testing
  • Tried deleting instance and starting over
  • Tried restarting computer (all 3 of us)
  • Tried restarting router

If you can connect from a different device on the same network, then the problem is with the port forwarding rules.