Folder permissions?

OS Name/Version: Windows 10 server 2016

Product Name/Version:

Problem Description: For some reason AMP is not able to read and write to the world folder. Keeps throwing back an error Multiple times. I try to change the permission but changed nothing it just reverts back to a read only folder/files. (This is a minecraft Java server instance.)

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1 - Restart server (move around.)
  • Step 2 - Leave server
  • Step 3 - Rejoining server

Actions taken to resolve so far: Googled everywhere. Checked different forums. Tried changing permissions. Hard restart. Restarting AMP.

What user are you giving permissions to? On Windows, AMP runs as “Network Service”

That fixed it! Thank you Mike. I was looking at all other permissions. But failed to do Network Service.