Firewall manager not installed?

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

Make sure you search before posting! Duplicate posts for the same issue may not be answered.

OS Name/Version: Linux - Debian GNU/Linux 12 on x86_64

Product Name/Version: AMP ‘Callisto’ v2.5.0.12 (Mainline)

Problem Description:

I am having issues connecting to my game servers. I have gone so far as to be able to see it on my local network, but I am not able to connect. When trying the “dumpfirewall” command I get the following output:

 CubeCoders AMP  amp@AMP-Boreas  ~  ampinstmgr dumpfirewall
[Info/1] AMP Instance Manager v2.5.0.12 built 31/05/2024 14:46
[Info/1] Stream: Mainline / Release - built by CUBECODERS/buildbot on CCL-DEV
[Error/1] No firewall manager available.

Is it possible to reinstall the firewall manager? or is at this point the best step to just reinstall the entire AMP VM?

Steps to reproduce:

  • Step 1: Start Amp
  • Step 2: Start game server
  • Step 3: try connecting to Gameserver
  • Step 4: Try connecting via AMP user and enter command ‘ampinstmgr firewall’

Actions taken to resolve so far:

none

That means AMP couldn’t find either iptables, ufw or firewalld on the system. One of those needs to be installed.

thank you very much! I am not sure what I did (did try rebooting a couple of times) but now the command does show me the ports and it appears to be all green. I can find the server with my public IP (so it appears to be running) but I cannot join it. I also cannot find it with my local IP Address. Not sure what I should create a ticket about with these symptoms.

Edit: I did try setting up a minecraft server, and that worked and I was able to connect to it. I was having issues with TF2 and Astroneer, which are both steam hosted. I am thinking that may be the reason?