Fails to Install app when Steam requires 2 Factor

OS Name/Version: Ubuntu 20.04

Product Name/Version: AMP

Problem Description:

Enter the current code from your Steam Guard Mobile Authenticator app
Two-factor code:Warning: failed to set thread priority: set failed for 8: -1: setpriority() failed
Warning: failed to set thread priority: set failed for priority 8
Warning: support for elevated priorities is most likely unavailable, suppressing future warnings
CHIDDeviceListSDL(): Couldn't load, not enumerating devices

Steps to reproduce:

  • Step 1: Have MFA on Steam
  • Step 2: Install Terraria Module
  • Step 3: Click Run/Install and put in Steam Login with SteamGuard Code

Actions taken to resolve so far:

Recreated new instance
Tried to Update or Run, same issue.

This is a known issue caused by SteamCMD releasing a bad update. If you attempt to update a few times it likely will work. Unfortunately, Valve hasn’t put out a fix yet.

It worked once on my first Terraria instance, but no matter how many times I try, it gets to the point where is says rate limited.

password: FAILED (Rate Limit Exceeded)

app_update 105600 validate

ERROR! Failed to request AppInfo update, not online or not logged in to Steam.

Isn’t there anyway to backdate the SteamCMD or run a beta of SteamCMD?