Fail to Extract Uploaded Zip File

OS Name/Version: Ubuntu 20.04.4 LTS

Product Name/Version: AMP

Problem Description: I successfully uploaded a file containing world data for minecraft to a minecraft java instance through SFTP, when i click extract here or extract to… it fails to unzip and doesn’t tell me why. I’ve tried sending small zips of 2 MB all the way to 760 MB. I have no clue why or how to fix this, since I cant seem to find a log with an error message anywhere.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1 Upload File
  • Step 2 Extract File
  • Step 3 Get Error

Actions taken to resolve so far: See above.

How did you make the zip file? What software produced it?

Ive used zip from Ubuntu and 7zip on windows both .zip files, same result.

As a workaround, I ended up going through ssh using root and “su -l amp” and going to the directory where the files were and used the native unzip instead of AMPs dotnetzip, and then gave the files the appropriate permissions and ownership and it worked.

Something about the dotnetzip is unable to unzip the files. I only found out that dotnetzip is used by amp because it left a tmp file after failing to unzip the file.

i have the same problem:

Could not read Path/to/file as a zip file

I uploaded it and tried the extract here option and extract to option.

It seems some permsissions are off? idk
I am using the server as a private instance running in an unraid docker container (with its own IP).
All works (minecraft server is running fine) but this failes.

i also have this problem.