Endpoint IP Address Change

OS Name/Version: Ubuntu 20.04.5 LTS

Product Name/Version: AMP Release “Decadeus” (2.4.2)

Problem Description:

I was playing around with AMP to get Valheim working and in doing that I bound the endpoint to a NIC on my server, so that the endpoint is stuck at 172.x.x.x:port. I later found that I should have left it at so that AMP listens on all interfaces.

How do I revert the instance to without having to back up the server (world seed) and restore it to another instance?

Steps to reproduce:

Actions taken to resolve so far:

The endpoint is actually just for display purposes, it’s not actually used for anything.

Hmmm… so what use is the setting in the main Network configuration (I think it’s where you change what new instances get by default)?

That doesn’t change existing instances. Changing existing instances is done from within that instances configuration.

Thanks. Can you tell me how to change an existing instances’ configuration?

In GenericModule.kvp in the instance datastore you can change App.ApplicationIPBinding. Stop the instance first

I used Ubuntu host terminal to nano that file and after restarting the instance the IP address is still 172.x… in the AMP interface.

That’s just a display. The actual binding will have changed (check with netstat). The display binding is in AMPConfig.conf for the instance

So, I stopped AMP entirely, and went in to AMP’s /instances/Main directory and changed AMPConfig.conf to:

That setting stayed that way after starting AMP back up.

I then went into /instances/Valheim01 and edited GenericModule.kvp to, App.ApplicationIPBinding=

That setting stayed that way after starting AMP back up.

In the same directory, I then edited AMPConfig.conf to Webserver.IPBinding=

This keeps reverting to 172.x when AMP and the Valheim instance are restarted. I should have looked at the commented text, because it says to use “ampinstmgr rebind” to change this.

I was referring to AMP.PrimaryEndpoint in AMPConfig.conf

Indeed do not change the AMP webserver binding via editing that file

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.