Don't starve together Overworld & Cave Cluster Problem

OS Name/Version:
Windows Server 2019

Product Name/Version:
2.4.8 - 20240129.1


Problem Description:
My cluster creates 2 overworlds instead of 1 overworld and a cave.

Steps to reproduce (My cluster/server settings):

Since as a new user you can only create a maximum of one embed, I unfortunately cannot send screenshots of my settings and unfortunately I have to show it that way now. Sorry for that!

Master (Overworld):
cluster.ini

[GAMEPLAY]
game_mode=survival
max_players=64
pvp=false
pause_when_empty=true
[NETWORK]
cluster_description=Deutscher Vanilla Server 
cluster_name=myservername
cluster_intention=social
cluster_password=
[MISC]
console_enabled=true
[SHARD]
shard_enabled=true
bind_ip=0.0.0.0
master_ip=127.0.0.1
master_port=7882
cluster_key=myclusterkey
[STEAM]
steam_group_only=false
steam_group_id=0
steam_group_admins=false

server.ini

[NETWORK]
server_port=15001
[SHARD]
is_master=true
name=MasterShard
id=100
[STEAM]
master_server_port=8766
authentication_port=27016
[ACCOUNT]
dedicated_lan_server=
encode_user_path=true

Slave (Cave’s):
cluster.ini

[GAMEPLAY]
game_mode=survival
max_players=64
pvp=false
pause_when_empty=true
[NETWORK]
cluster_description=
cluster_name=myservername
cluster_intention=cooperative
cluster_password=
[MISC]
console_enabled=true
[SHARD]
shard_enabled=true
bind_ip=0.0.0.0
master_ip=127.0.0.1
master_port=7882
cluster_key=myclusterkey
[STEAM]
steam_group_only=false
steam_group_id=0
steam_group_admins=false

server.ini

[NETWORK]
server_port=15003
[SHARD]
is_master=false
name=Cave
id=200
[STEAM]
master_server_port=8767
authentication_port=27017
[ACCOUNT]
dedicated_lan_server=
encode_user_path=true

Actions taken to resolve so far:
I tried resetting the two AMP instances and setting the cluster settings again

I’m also having issues with configuring my cluster. Where are you editing these files?

I found that editing the ones at /home/amp/.ampdata/instances/DontStarveTogether01/dont-starve-together/343050/dstserver/dstserver_config/Cluster_1 doesn’t seem to produce the expected results and gets overwritten. Perhaps this is part of your issue?