Domain name change issues

OS Name/Version: “Debian 11”

Product Name/Version: “AMP Instance Manager v2.4.3 built 14/03/2023 21:50”

Problem Description: Cannot login after domain name change but login screen does show up in browser under new domain. I tried to change the domain name the way I have on other servers after the domain had expired and I was unable to get it back.

When trying to log into the panel on the login screen (which does come up) and the credentials input correctly, it does not log in and puts me back at the login screen with no errors thrown on the login page or in the servers journal.

I was unable to find anything like this in the support center.

Steps to reproduce:

  • Use the terminal to change the NGINX config to a new domain’ from the /etc/nginx/conf.d configuration and change only the domain name itself and the certbot certs to the new domain
  • Generate new SSL for the new domain with certbot
  • Restart NGINX

Actions taken to resolve so far: Attempted to use the following ampinstmgr commands with no changes.

  • RepairAuth
  • ValidateInstance
  • RebindInstance

None of these did anything as they would not accept the instances or server domain
I did attempt to restart AMP services and the server itself.

  • Update ampinstmgr to the latest version ( at time of writing)
  • Run getamp postSetupHTTPS as root

I do not see a getamp command and the repo of is saying it’s gpg key is invalid.

That’s because you’ve fallen too far behind:

This appears to have worked!
It did also end up requiring a password reset, as my security key didn’t work anymore, but other than that it worked perfectly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.