Docker does not appear to be installed after following FAQ

OS Name/Version: Linux Mint 21.3 Cinnamon 6.0.4

Product Name/Version: AMP Callisto

Problem Description:

Tried to install Sons of the forest, never worked, installation screen suggested Docker as recommended installation method, read the docker installation FAQ, followed the steps, installed Docker:

Please wait while GetAMP examines your system and network configuration…

  • Checking installed packages…
  • Checking environment…
  • Checking network configuration…
  • Detecting network type…
    Installing Docker…
    gpg: no valid OpenPGP data found.

Enabled “Create in Docker Containers” made a new instance and ran into an error, no docker installed.

This instance either requires or has been configured to use Docker, but Docker was not found on the system.

The FAQ is not clear, does this command install docker as a whole or install a docker compatibility for AMP and I need to install docker separately?

bash <(wget -qO- installDocker

Searched forums and found no other topics in relation to this issue.

Have you restarted AMP since installing docker? That command does everything for you.

First time I tried yes, rebooted the box, ran into error when creating new instance, ran the commands again without rebooting to get the text for post and checked ‘docker info’ etc which also claims no docker installation found.