Default auth server does not auto adjust

OS Name/Version: Ubuntu Desktop 22.04 (and tested on 20.04)

Product Name/Version: v2.3.3

Problem Description: When running the bash one-line install while another program is using port 8080, the install correctly adjust for this and moves to the next available port when setting up ADS01. Problem is, it does not adjust for this change in the config file for the “Default auth server” line. it remains at port 8080. This causes issues for creating your first instance or any instance. Changing this is super easy but was kind of thrown off that it did not take into account that ADS01 was using port 8081 and not 8080. I also tested this on Ubuntu 20.04 on a freshly setup machine, first installing one program i knew would take up port 8080 and then immediately installed AMP right after. Same result.

Steps to reproduce:

  • Step 2: continue onto the web setup process. keeping all selections to default.
  • Step 3: create first instance, you will get error letting you know there was an issue with the default auth server. this is where you can tell that the setting here does not reflect the same port used during install (this port was not manually selected, it was auto selected based on what was available beyond port 8080)

Actions taken to resolve so far: Configuration → New Instance Defaults → Change Default auth server to the same port as ADS01

What mode did you specify during installation? Normally it sorts it at that point for you.

The standard recommended mode (standalone) during both installs. I did although chose the letsencrypt option during both installs to 2 different domains I own. So I did not test without this option.