Customization with Valheim - Adding Bepinex Causes the Server to fail to start

System Information

Field Value
Operating System Windows - Windows 11 Pro on x86_64
Product AMP ‘Proteus’ v2.8.0.6 (Mainline)
Virtualization Xen
Application Valheim
Module GenericModule
Running in Container No
Current State Stopped

Problem Description

Issue

Server fails to start when any method of installing Bepinex is used. AMP toggle & manual. I tried editing the bepinex config files to point directly to the strict file path of the valheim_server.exe file and it still fails.

Reproduction Steps

  • Deleted instance, created new instance. Ran server, it started.
  • Stopped Server, went to Configuration > Updates and toggled Bepinex Standalone on, added the latest version “5.4.2351” into the field on the right.
  • Ran the server, it fails to start. tried removing Bepinex folder, and files, and installing manually in File explorer, same results, fails to start.
  • Tried multiple other things like pointing the Bepinex preloader files to the strict file path. Nothing seems to work. I haven’t even installed any mods, simply adding Bepinex is stopping the server from starting.