Customization with Minecraft - Unable to run a FTB Skies 1.3.1 server

System Information

Field Value
Operating System Windows - Windows 10 on x86_64
Product AMP ‘Decadeus’ v2.4.6.0 (Mainline)
Virtualization None
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Installing

Problem Description


I cannot figure out how to get AMP to run the current ftb modpacks, specifically, FTB Skies 1.3.1. I’ve even tried to select the FTB (New Source) server type and went with the older 1.2.1 version of the pack and AMP still has issues running it (keeps reinstalling it over and over again). I have even tried to rename the libraries folder within minecraft to libraries-old and AMP refuses to work at all at that point.

I think the issue is the way the modpack is designed to work. It uses a start.bat file that does NOT point to a server jar file but to a different file completely, which then points to yet another txt file within the libraries folder, which THEN points to a server jar, within the libraries folder. You can see what I mean by looking at the start.bat and the win_args.txt that I have pasted here Mozilla Community Pastebin/aMConHb1 (Plain Text). If AMP would let me select the server jar, I think it would work, but it just gives me that strict error.

Also, the status constantly either says: Application State: Installing components; or Unable to run.

Reproduction Steps

  • Download Windows Server files using this command: Invoke-WebRequest -Uri “” -OutFile “serverinstall_103_6561.exe”
  • Run serverinstall_103_6561.exe file
  • Run server.bat once
  • Move all installed files into AMP Instances minecraft directory
  • Set up server configuration for - Type: Forge; Version: 43.2.14
  • Attempt to start server
  • Watch server try to reinstall forge
  • Try to select forge server jar located in libraries folder within file manager. Get error: Could not change Server JAR - ‘forge-1.19.2-43.2.14-server.jar’ is not a valid value for ‘MinecraftModule.MinecraftSettings.ServerJAR’ as strict validation is enabled for this setting and the supplied value does not exist within this settings list of acceptable values.
  • Attempt to install 1.2.1 version of modpack using Feed The Beast (New Source) server type. Watch as AMP repeatedly installs modpack over and over.

Set the server type to forge, and the forge version to the version used by the mod pack.

That is already listed in the ‘Reproduction Steps’. Step #5, to be exact.

Don’t select a jar file, set it to automatic.

Same thing happens. It attempts to reinstall forge. Once again, this is more than likely because it is not coded to see the forge server files in another directory other than base. Keep in mind, the server works perfectly fine, outside of AMP.

AMP is designed to accommodate modern forge servers that don’t use a standard jar file.

Try building the server the other way around, start by having AMP install just the forge version it uses, then add the mod packs.

The problem is that all of your suggestions are telling me to NOT use the server jar that comes with the mod pack. I mean, even your own ‘Feed the Beast (New Source)’ fails to install and run the mod pack. When I go that route, it fails to see a server jar and thinks it isn’t installed and tries to install it again. Sure, if I was to completely install forge separately from the mod pack and use that one instead of the one included with the mod pack, I am fairly certain the server would start up. However, since we will have changed the way the mod pack was designed to work, how will that effect the performance of the server? After all, if you look at the linked start.bat, you’ll see it is suppose to start with the log4jfix/Log4jPatcher-1.0.0.jar file and then go to the win_args.txt file. But, with your suggestions, the Log4jPatcher and the win_args.txt are completely ignored.

It won’t be different in the slightest.
The pack just downloads the exact same Forge files as you normally would. (and the exact same files that AMP then downloads)
And the Log4J patcher is redundant, as the server is newer than 1.18.1 and the Log4J exploit has been fixed in Forge anyways.

Have you checked what the support tab says just after starting the MC server? It’ll show you what arguments it’s starting Java with.

Ok, I did not know that about the support tab. This is the arguments it’s starting with:

-Xmx12288M -XX:+UseG1GC -XX:+UnlockExperimentalVMOptions -Xms8192M @libraries/net/minecraftforge/forge/1.19.2-43.2.14/win_args.txt

So it is still accessing win_args.txt. This whole thing has been completely confusing because when you do the ‘forge type’, the messages it writes into console makes it seem like it is completely overwriting what is there. I have accepted Mike’s original answer as the solution and I will now copy over the world files. As far as this issue goes, I consider it fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.