Customization with Minecraft - Forger download version isn't working and only stays from 1.20-1.20.4

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.0 (Mainline)
Virtualization Docker
Application Minecraft
Module MinecraftModule
Running in Container Yes
Current State Failed

Problem Description

Issue

I am trying to switch the version of the forge downloader in the server settings, but every time I try it gets laggy and only gives me access to the versions 1.20-1.20.4. I would like to play on 1.16.5.

Reproduction Steps

  • Install forge (won’t let me change the version of forge)
  • Try to change the version (it won’t let me)
  • 1.16.5 version not compatiable

The Forge version list is pretty long, you’d have to scroll down a bit to get to 1.16.5. Should be possible though, I run a Forge 1.16.5 server myself.
Also be sure to switch to the Java 8 or 11 runtime depending on the mods you have installed.

Thank you for your help with this!