Customization with Minecraft - Can´t add add-ons on a Bedrock server

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Decadeus’ v2.4.7.0 (Mainline)
Virtualization Docker
Application Minecraft
Module MinecraftModule
Running in Container Yes
Current State Stopped

Problem Description


Good morning. I´ve been trying to apply add-ons on the server for quite a while and tried everything I could, such as inserting ZIP files, extracting them, coding their IDs and inserting their versions; inserting a custom world with the add-ons on them etc. I´m having quite of a struggle to try to add them into the server and some assistance would definitely help.

Reproduction Steps

  • tried to paste behavior and resource pack folders directly into their folders to no avail
  • pasted a ZIP folder of both Behavior and Resource packs into their respective folders
  • extracted them into their respective folders
  • inserted a .json file for both BP and RP
  • coded them by inserting their IDs and versions into the .json file (which is inside the world file)
  • deleted the previous ZIP files, as they had no use anymore
  • started the server, which hasn´t added the add-ons

Microsoft don’t make it easy to add add-ons to servers. It honestly might be easiest to apply the addons to a single-player world, then upload the world to the server

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.