Custom world with mods error

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version:

Product Name/Version: (Always use the full version number - not ‘Latest’)
VPS Minecraft Creeper
Problem Description:
Me and some friends have been playing in another minecraft hosting for a while now, with our customized world.
The thing is that we configured the hostinger server following tutorials and everything seemed to work properly; we installed minecraft forge and some mods and it worked with a NEW world.
But when we unzip our world into the minecraft directory and try to start the server, some error appears on the screen.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1
    First, we started the server without the mods and with the default world to check if the server worked. Everything was great.

  • Step 2
    **Then, we installed the forge version 43.2.0 (mc 1.19.2) and we finally uploaded the mods directory (already compressed, via FileZilla into our minecraft Hostinger directory. **

  • Step 3
    We unzipped our mods directory and we started the server to check if it worked fine with all the mods (with the default world). It worked.

*Step 4: We uploaded our into our minecraft Hostinger directory as we did before, and the unzipped right away. (The server was stopped)
*Step 5: We selected our world in Configuration → Server settings → Level Name “world”.

*Step 6: We started the server and a few minutes later appeared an error.
Sometimes it’s a “Killed by user error” The server can’t start" Or something like that.
And some times the Game panel goes down and we have to restart the VPS to enter to the Game Panel again.

Actions taken to resolve so far:
1- Tried to use a default world to check if it worked well with the mods.
2- We also tried to upload our custumized world directory to hostinger in differents ways; like dragging it directly to the browser (first we tried unzipped and then zipped).
3- At first it appeared this error: java.nio.file.AccessDeniedException: ./world/session.lock

So we tried our best to find a solution on the internet but we couldn’t find anything useful.
We just eliminated session.lock file and checked if that was the one corrupted but it didn’t work.

We come from aternos free hosting, so we don’t know if our directory has a corrupted file or if we are uploading it the right way.

Any help you can provide would be greatly appreciated.

Thanks and good evening to you all.


If you’re using Hostinger, you should ask them for support. You’ve got a permissions issue but they’ll be able to advise better on the correct way to do things with their setup.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.