Csgo srcds - does not startup at all

OS Name/Version: Ubuntu 22.04.1 LTS

Product Name/Version: (Always use the full version number - not ‘Latest’) AMP Release “Halimede”
v2.4.1.2, built 21/12/2022 17:54

Problem Description: When I go to start a CS:GO server in the Status page the instance will first tell me “The srcds server must be bound to a specific IP address rather than to function correctly in AMP. You can change this setting under Configuration → Source Server Settings → Server IP address”. Also side note, when the updates are done, on the status page in the top right it says that the server is unable to run.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1 - Create CS:GO instance
  • Step 2 - Update and download, wait
  • Step 3 - Click Start on the Status page of the instance

Actions taken to resolve so far:

  • Changed to 192.168.0.x in the Source Server Settings - Server IP address. When I clicked to start it would do nothing for about 2 mins then stop the instance entirely.
  • Tried the loopback IP and same result as the first.

Have you set a GSLT token?

I have, I get the same results unfortunately

Do you get any output in the console?

I do not get anything in my console, but when I went and checked my logs, I’m getting a constant “The application stopped unexpectedly. Exit code 255”

Can you show me all of the information from the Support tab please?

Also after like 5 mins of trying to start it, it stops the instance

Do you have crash reports turned on? Also can you check dmesg for any OOM errors?

I think I do, I don’t know how to check to see if I do have crash reports turned on. But I do get this in my amp logs if that is what you are talking about,

[12:59:12] [Core:Anonymous Error] : [0] (SocketException) : Connection refused
[12:59:12] [Core:Anonymous Warning] : Returned exception from API call ADSModule/Servers
[12:59:12] [Core:Anonymous Error] : SocketException

I’m getting that constantly in the logs when I try to run it.

Also, my system has 16GBs of RAM and this is only the 2nd instance I have on it so I don’t think its a memory issue. Tell me if I’m wrong though, please.

Wrong logs, those are the logs for ADS rather than the specific instance.

Then no OOM error(s) in dmesg

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.