Connectivity Problem with Satisfactory - Can't connect to server on update 8 [experimental]

System Information

Field Value
Operating System Linux - Ubuntu 20.04.6 on x86_64
Product AMP ‘Decadeus’ v2.4.5.4 (Mainline)
Virtualization Docker
Application Satisfactory
Module GenericModule
Running in Container Yes
Current State Ready

Problem Description


I am running the latest experimental version of update 8. The server seems to start and run fine through AMP though I get the following error message when trying to create or join the server via the client.

UNetConnection::Tick: Connection TIMED OUT. Closing connection… Elapsed: 20.01, Real: 20.01, Good: 20.01, Driver Time: 20.02, Threshold: 20.00, [UNetConnection] RemoteAddr:, Name: IpConnection_2147407656, Driver: PendingNetDriver NetDriverEOSBase_2147407657, IsServer: NO, PC: NULL, Owner: NULL, Uniqueld: INVALID

I am connecting to the server via LAN do an always on dedicated server. AMP is running in a docker container on Unraid. I can see the client attempt to connect on the AMP server console though after a few seconds it outputs the same error as the client.

Reproduction Steps

  • Create Satisfactory server on AMP
  • Update server to latest Experimental Update 8
  • Start server
  • Find Server through Server manager on Satisfactory Client via LAN
  • Attempt to connect where the error message appears after a few seconds. Error message detailed in Description.

What port are you trying to connect on?

Just worked it out. Had to change the “UE4Server” to “UnrealServer” in GenericModule.kvp

That was addressed a while ago in the template. Yours must be out of date.

Right click on the instance, Refresh Configuration (assuming you have a standalone setup) and then manage the instance and update the server

I did try that but it didn’t seem to work. I was trying a few other things at the same time though so that might have messed with it.


After clicking Refresh Configuration, check the ADS console for any GitHub errors.

You also must update the server (not the instance) after refreshing the generic config

Just ran the refresh and update again and it reverted the file back to “UE4Server”. doesn’t seem to be any GitHub errors either.

Yes, expected. The template has to cater for both early access and experimental, which have different binary names. When you update the server a copy will be made of the experimental with the old name, and the template runs that

Ok. So I just have to manually change that line in GenericModule to “UnrealServer” again? both current and .old have the same “UE4Server” after refreshing and updating.

No. The template does it all for you

Is it possible my system is still downloading an old template? No matter what I do regarding refreshing and updating it still seems to re write the file to “UE4Server”.

I’ve tried refreshing the instance both running and stopped. Restarting the server inside the instance in various different orders and it always just comes back as “UE4Server”.

You’re not reading what I am saying.

GenericModule.kvp has the old binary name. But the template makes a copy of the experimental binary and names it the old binary name. So when AMP runs the old binary name, it is actually running the experimental server

Had to do it this was as only one binary name can be specified in the kvp

Ok so it turns out. after going through that refresh/update it reverted me back to the start with the original fault. It was not in fact the UE4/Unreal issue though that might have been the problem at the start. it was actually having “MultiHome” argument in CommandLineArgs. This was something I tried before but got distracted by the other issue. Once I deleted -MultiHome from GenericModule.kvp it worked again.

Sorry I didn’t fully understand you before. I was confusded with the GenericModule.kvp and GenericModule.kvp.old thinking this is what you were referring to where the template would automatically adapt. I thought it would re write one of those files when updated but that’s not the case.

Either way it seems to be solved. At least that issue for now.

Thanks for the support.

Having MultiHome in the args should not have caused your issue, if anything it should fix connection issues because it disables the Satisfactory server’s internal packet router

I followed that advice from Discord from Marie T. as a pinned message that said to remove it if you’re having connectivity issues on Experimental.

I do however get a new error after disconnecting from the server then reconnecting shortly after.

UNetConnection::Tick: Connection TIMED OUT. Closing connection… Elapsed: 30.05, Real: 30.01, Good: 30.01, Driver Time: 35.52, Threshold: 30.00, [UNetConnection] RemoteAddr:, Name: IpConnection_2147445326, Driver: GameNetDriver NetDriverEOSBase_2147445327, IsServer: NO, PC: BP_PlayerController_C_2147444740, Owner: BP_PlayerController_C_2147444740, Uniqueld: Steam: (STEAM)Max Power [0x1100001072EFAFA]

Restarting the server seems to fix it but as soon as I connect, disconnect then reconnect again it happens.

Maybe not having MultiHome has contributed to this new fault?

That advice is from ages ago and I am not even sure what it is based on.

See eg: Satisfactory Q&A

For the new connection issue, try extending the timeout in the AMP UI (under Server Settings). Eg make it 60

It is at 60 already. Both Initial and Established timeouts are at 60sec from when I was dealing with it before. I just reselected them to ensure they saved again and I can see it written in GenericModule.kvp too under App.AppSettings

You wouldn’t be the first person with issues run Experimental v8. See the Satisfactory discord lol.

Haha yea that’s what’s giving me the idea to just wait out a bit until it gets more stable.

I think I’ll just leave it for now. Thanks heaps for sticking with me this far.