Configuration with Valheim - Sleeping is not working

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.6 (Mainline)
Virtualization Docker
Application Valheim
Module GenericModule
Running in Container Yes
Current State Ready

Problem Description


Yesterday I bought my license and I installed this on a Proxmox LXC Debian Instance (recommended distro from your docs). The Valheim server, after 5 min idle, was getting “sleeped” and after trying to connect to the instance ingame, server was booting automatically. This behavior has stopped working from yesterday after (maybe) game has updated. Did the docker images changed, o has been any other update on the last 24h that may have affected the sleep functionality of Valheim or is this a isolated case? Thanks!

Reproduction Steps

  • Fresh install of AMP with new license.
  • Fresh install of Valheim server.
  • Sleep not getting triggered with default “sleep” settings, not even by triggering manually.


Hi again,

I think I managed to find a workaround in case someone has same issue.

  • Stop the server manually.
  • Enable “Configuration > Performance and Limits > Sleep On Start”.
  • Start the server and should start as “Sleeped”.
  • Click “Wake Up” and wait 5 minutes for sleep mode (delay default setting). In my case at 5:20s server switched to “Application Sleeping”, as in following screenshot.

I think maybe the reason is “Server startup timeout sleep threshold” in Performance tab. This is set to 25 seconds, and the first time server is created, it may take more than expected to boot up and silently disables the sleeping even though is enabled.

It would be creat to have a log in case this behavior happens, or by clicking on “Sleep” have a popup with a message such as “Server startup timeout sleep threshold reached, Sleep is not available, try to update and restart”, or something similar :smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.