Configuration with SCP: Secret Laboratory - Server will restart whenever a command is entered

System Information

Field Value
Operating System Windows - Windows 10 Home on x86_64
Product AMP ‘Decadeus’ v2.4.6.2 (Mainline)
Virtualization None
Application SCP: Secret Laboratory
Module GenericModule
Running in Container No
Current State Ready

Problem Description


When I am trying to setup a mod for the sever or enter any kind of command the server will restart when a command is entered into the console. I can’t enter any kind of command without this happening. It won’t run any command and will only restart the server.

Reproduction Steps

  • Start Server
  • Wait for server to be running
  • Issue any kind of command
  • Server will restart

Interesting. This wasn’t an issue in testing. I can see LocalAdmin reports an unhandled IO exception. The same doesn’t happen on Linux.

I see the server was just updated on Steam a couple of days ago - might be connected with that. Or it could be something to do with how AMP’s console communicates with the server. Interesting though that the console works fine when accepting the EULA.

That was my thought as well. I have tried to reconfigure the server and I also deleted the instance to see if the issue continues. I am still unable to type any commands in the server without it restarting.

Did some testing. It’s not the server, coz when I run it from the command line it is fine. It’s AMP’s console interaction with it. I’ve tested a configuration change to the template and that appears to deal with the issue of server restarts. It means in some cases not all server output is shown right away in the console, but commands do otherwise appear to work.

Will raise a PR to implement this change shortly.

Actually, might have an alternative. Try this:

Stop the server. Go into AppData/config/<gameport>/config_localadmin.txt through the instance File Manager. Change la_no_set_cursor to true. Save and exit.

Now start the server and see how it behaves.

Given this appears to resolve the issue, the template has now been updated to include the fix.

Right click on your instance, Refresh Configuration to get the latest. If you are using controller and target, then you need to Fetch Latest under Instance Deployment first

That fixed it. I had to go in and change it cause when I reinstalled the Template cause the effect didn’t change. But changing it in the local admin config fixed all the issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.