Configuration with Minecraft - TPS profiler not displaying?

System Information

Field Value
Operating System Windows - Windows 10 Pro on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization None
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Stopped

Problem Description


Minecraft version 1.20.2
Is it just that Windows doesn’t support showing the profiler (Did I miss reading something)?
I have tried Official server, and Fabric, they both just say that the command “tps” is not recognized. Paper seemed to install Spark on its own just fine, but the output stated that the async profiler only works on Linux.
I tried manually adding Spark to the Fabric server, and it will show in console, but not the profiler on Metrics and Status.

Reproduction Steps

  • TPS Profiling is enabled by default.
  • Enable Full profiling on AMP
  • run server

Not all server types support TPS monitoring. Only those that support the “tps” command which AMP runs periodically to collect the information. Some servers output the TPS in a format AMP doesn’t recognise (which would be the case if it’s provided via a plugin rather than built-in) which also prevents it from showing up.

Would you happen to know offhand which server types support the profiling for AMP? Very appreciated for your fast response and help btw.

I do not, no. I don’t think there even is a fixed list in any meaningful sense. AMP just tries the command and sees what happens.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.