Configuration with Minecraft - gets reset when I start the Minecraft server

System Information

Field Value
Operating System Linux - Ubuntu 22.04.2 on x86_64
Product AMP ‘Decadeus’ v2.4.6.4 (Mainline)
Virtualization None
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Stopped

Problem Description


I installed sky factory 4 and started the server. I logged in and it was a basic world. I looked at the and it had ben overwritten by the server settings. I tried to rewrite the file in AMP but it got overwritten again.

Reproduction Steps

  • Downloaded sky factory 4
  • Installed it
  • Run the server

If you make manual changes or want to use an existing server.propeties, you need to import it by right clicking it in the file manager.

I tried it and it gave me this:
Screenshot 2023-10-01 151353
And it still gave me a normal world.

Stop the server, delete the world dirs, check settings in UI are as desired, start server

I tried and it didn’t work.
It keeps completely changing the file.
here is the file before I start the server:

The generator settings can be formatted a bit weird, usually best to input those in the AMP web UI

(Note you don’t need the \ before the colon in AMP)

I cant get the \ to go away

Here is the file after I started the server:

The \ should be in the file, just not in the AMP web interface.
(in the file it basically says “hey, it’s fine if I put this : here”)
Before each attempt at starting the server be sure to delete the world folder, as the world generation settings are locked in when the file is created.

If it still refuses to work, you can generate a world in singleplayer, then upload it to AMP and rename it to world

I tried doing the singleplayer method but it crash.
Here is the crash report:
Screenshot 2023-10-01 163642

There’s a lockfile that prevents you from accessing a worldfile from multiple servers/clients at the same time, you might’ve copied over the world while you still had it open in singleplayer.
Easy fix though, you should be able to go into the world folder and delete the session.lock file.

I did that and still got a crash.
Here is the crash report:
Screenshot 2023-10-01 165245

Welp, re-upload the world again and make sure the client doesn’t have the world running while doing so

I tried re-uploading the world and creating a new one but I get the same crash.

I’m not entirely sure why that would be the case.
Next idea:

  • Change the value under Server SettingsWorld Name to something like “test”
  • Generate a fresh world using the server
  • Use SFTP to copy the session.lock from test to world
  • Change the value under Server SettingsWorld Name back to “world”

Alternatively you could wipe world, generate a new one on the server, then copy over everything inside the client world except for the session.lock

for same reason both ways turn the would to normal.

Well, I’m out of ideas, I’ve run SF4 fine with AMP before, not sure why you’re running into funky issues with the worldgen

Ok thank you for all the help

I think I am having a similar issue.
I have edited the file to change online-mode=true to online-mode=false When I click the import configuration button, I get a popup that shows some items were not imported. One of these items is the online-mode.
I am trying to set the online-mode to false for the backend servers using waterfall/bungeecord. Any reason I can’t import the changes, or anything else I can try?

If you’re using a proxy, there’s a setting in AMP that needs changing. Type “Proxy” into AMPs search box.

I knew it was going to be something simple that I missed…
I set the flag for standalone server off and it works as expected.
Thank you!