Configuration with Minecraft - I can't change the online command

System Information

Field Value
Operating System Linux - Debian GNU/Linux 11 on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization QEMU_KVM
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Ready

Problem Description

Issue

When you turn on the server, only the online mod:false command is changed to the online mod:true command. My configuration changes are not saved

Reproduction Steps

  • open the serverpropierties file in file manage
  • edit the command online mod:true to online mod:false
  • turn on the server and put the command online mod:true again

Hi there! I’m going to assume you are referring to the online-mode setting in your server.properties file.

Before we proceed, I want to clarify that changing the online-mode to false is only allowed when using a proxy such as BungeeCord or Velocity. This is because this setting is used to allow non-paying users to join a server, which is something we don’t support.

Can you please confirm whether you’re using a proxy or not? Without this confirmation, I can’t assist further on this matter.

I use hostinger game panel, is it possible to change it from here?

Absolutely, however, I’ll reiterate that the online-mode should only be set to false if you are using a proxy server like BungeeCord or Velocity. All Minecraft servers should run in online-mode to ensure player authenticity. Could you confirm if you are using a proxy server like these?

No, how can I purchase one if I host my server from Hostinger?

Apollo stop replying.

Using a proxy won’t let players who haven’t paid from playing the game so you need to be clear about what you’re trying to do. We won’t aid in piracy here.

Understood. As per Mike’s instructions, I won’t be able to assist any further. Please connect with Mike for more assistance regarding your query.

I have paid, I am the creator of the server, I want to change that command because I access my minecraft launcher from curseforge and it does not let me access the server as an invalid user, that is my problem

It’s important to provide errors when creating a post.
Disabling online to fix that error is never a solution. Disabling online allows unauthenticated users to join and really just messes up player data in general.
The fix for unable to verify username would be here:

Alternatively, if that’s not the problem, Microsoft’s auth servers have been buggy in some regions the past couple days. If that’s the case you’ll just need to wait it out.

Thanks, it worked for me, but now I get this error when I enter and I don’t understand why it is

Is it a Forge/Fabric server?

it´s a forge server jjjjk

I would suggest double checking that the versions match properly and that you have the right mods installed on the client

Thanks, would you have any advice to find out which mood is the corrupt one? because when starting the server no error appears, it is simply in minecraft

You would have to read what the error says in the client logs (and check if the server log says anything), otherwise you can do some trial and error with the mods to see if you can narrow things down.

Thank you very much for your help, do you think that minecraft: smelting is not a cooking recipe has something to do with the problem information? Could an oven mod be the problem?

Possibly, it would be good to check any cooking/smelting related mods first

internal exception: io.netty.handler.codec.decoder.exception:java.lang.illegalargumentexception:type´campfire cooking is no a recipe error minecraft

Could you already find a solution? Which version do you use? Maybe you have a Mod for a newer version as the server ist set to.