Configuration with Minecraft - How to disable Minecraft Bedrock LAN discovery

System Information

Field Value
Operating System Windows - Windows 11 Pro on x86_64
Product AMP ‘Decadeus’ v2.4.5.4 (Mainline)
Virtualization None
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Ready

Problem Description


I would like to disable LAN discovery as it causes problems when running two MC servers.
Thank you :slight_smile:

Reproduction Steps

  • I have tried amending the default ports using “edit ports” option to something that is not the default (19132), though this still kept the LAN discovery port as 19132
  • I have used the documentation help within the instillation folder within the instance which advised me to add "enable-lan-visibility=false to the server properties.
  • I have asked for assistance in the Discord, but no one seemed to know how to get it to work.

Did you import the after editing it? (Right click → import in File Manager)

Hi Mike,

Thank you for getting back to me so quickly.

I just tried that, but it has failed:

Kind regards,


Double-check the file. Change the value to false, import it (ignore the warning), hit start, check the file again and see if it still says false.

I have done this and the property stayed as false, but the server is still using 19131 for LAN discovery.

Check using AMPs file manager instead of outside of AMP, check what the value says while the server is running.

No change.

If it’s correct in then this is an issue to take up with Mojang and unrelated to AMP itself. I would check however that LAN discovery is actually enabled by trying it. It may not log that LAN discovery is turned off and just says that generally.

It is correct in the, but just isn’t working correctly. It’s like AMP is ignoring the flag. I know it isn’t a Mojang problem, as it works perfectly when hosting outside of AMP.

There is also the problem that AMP can’t support more than one Minecraft Bedrock server, due to the first one having LAN discovery bound to 19132, preventing the second server from starting.

If i had to guess, the second instance is trying to establish LAN discovery.

AMP by definition doesn’t have anything to do with any in-application behaviour beyond setting the config file and starting the process. You can validate this by using AMPs script generation mode to replicate how AMP starts a process without involving AMP itself (although using it on Windows isn’t that helpful because it’s tricky to start the process as the correct user)

AMP sets server-portv6 to server-port +1, so make sure that any Bedrock instances are always 2 ports apart to avoid an overlap.

Okay so after further testing. I have found a possible work around. If i change Server 1 port to 19140, this seems to disable LAN discovery, according to the console.

I boot server 2 and it uses 19132 for LAN discovery. Which i wanted for the second server as it is for my kid who plays on xbox.

Though Server 1 is stuck starting, even though i have been able to join and confirm it is up and running. Is there anyway to force the server to see that is has started?

I hope that made sense. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.