Configuration with Counter-Strike 2 - Cant connect to RCON

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization Docker
Application Counter-Strike 2
Module GenericModule
Running in Container Yes
Current State Starting

Problem Description


Hello there, Iam new to this server stuff.
I managed to create a cs2 server, but cant connect to rcon.
I used the standard way in cs2:
rcon_password mypassword

Connect to Server → Rcon wont work.
What did I do wrong? :frowning:

Reproduction Steps

  • Disabled random RCON password
  • Cleared RCON Password
  • Set RCON password in csgo/cfg/server.cfg

i have the same problem :frowning:

You have to use the “Custom RCON password” option. Setting it via other means will cause things to stop working.

Lol, CS2 is not the srcds module, Mike

OP, AMP needs to control the password as it uses RCON for console. Unfortunately we don’t have the ability with the generic module to set our own password manually so you have to use AMP to set it. (Mike, change this!)

Derp - doesn’t the Generic version have basically the same setting somewhere though?

Do you know your own software? xD

You put the generate button under Security and Privacy - as the screenshot above refers to.

But as stated many times before, what people really want is to be able to specify their chosen password through the UI. That you haven’t made available to generic

Ah indeed, that won’t happen. Generate only with AMP in control of it.

First of all: CS2 Rcon is broken within CS2 itself but can be accessed through external Tools.
So the problem changes from cant access from server to:

Cant set my own rcon password.

So I cant set my own password, even with the configuration file?
The server must save the password I randomly generate, anywhere?

If I try this btw, server wont start anymore lol.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.