Colliding ports when running multiple Minecraft instances

OS Name/Version: Windows server 2019

Product Name/Version: AMP 2.4.2 / Minecraft server (bedrock)

Problem Description:

When creating a new Bedrock server (this was number 4, the other 3 are years old and work fine) I specify a new port for the instance, in this case 19162.
When the server starts in outputs:

´IPv4 supported, port: 19162: Used for gameplay

And a bit further down in also allocated port 19132 for “LAN discovery”

´IPv4 supported, port: 19132 used for LAN discovery

This renders one of the old server unable to start since this uses port 19132

Where do I change this “LAN discovery” option?

Note that the old servers outputs

´IPv4 supported, port: 19132: Used for gameplay and LAN discovery

Steps to reproduce:

  • Step 1
    Create a new Minecraft bedrock server
  • Step 2
    Assign desired port
  • Step 3
    Start instance

Actions taken to resolve so far:
Deleted instance/create new again
Checked instances.json
Restarted both AMP and the whole server several times

I ran into the same issue…

  1. When creating the instance set the port to what you would like it to be, I will use 19150 for example. Make sure the instance DOES NOT START upon creation. Create the instance.
  2. Create a separate bedrock instance with port 19160. MAKE SURE IT DOES NOT START UPON CREATION.
  3. Start the first instance of bedrock up and start the server, check the MC console logs to make sure the correct port is being opened. They should be 19150 and 19151.
  4. Exit out and start the second instance, start the server, make sure the correct ports are displaying. Should be 19160 and 19161.

TL;DR - You cannot use the default port values for bedrock for whatever reason… Use custom ports. You may have to recreate the instances with the correct ports so collisions stop happening.

This does only partially work! I created a 2nd intance that way and all worked fine, until the update to 1.19.71 arrived… so i restarted the docker container and now it is again:

 IPv4 supported, port: 19132 used for LAN discovery

b4 this restart it was using the configured port for discovery.

Where is this discovery port set? Shouldnt it use the values set in

It should be in the AMP port binding settings I believe, That would then set the folder. You may have to delete the instance, turn off “Start instance upon creation”, create a new MC instance, edit the port / IP bindings to be custom (ex: 19150) and then start the instance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.